Bug 2515 - binary files are not stripped after make
binary files are not stripped after make
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.12
Sparc Solaris
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 06:08 UTC by Ralf Gross
Modified: 2006-01-17 21:17 UTC (History)
0 users

See Also:


Attachments
config.log (solaris) (57.38 KB, application/gzip)
2005-03-22 09:39 UTC, Ralf Gross
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Gross 2005-03-22 06:08:35 UTC
After the make run, binaries are not stripped. This results in ~1.1.GB data in
the source directory. make install tried to copy theses 1.1GB to
/local/samba-3.0.12 which ended in a full /local filesytem. I can reproduce this
behavior with debian testing too.
Comment 1 Gerald (Jerry) Carter 2005-03-22 09:08:22 UTC
what compiler (and version) and what configure flags are you using?
Comment 2 Ralf Gross 2005-03-22 09:36:18 UTC
(In reply to comment #0)
> After the make run, binaries are not stripped. This results in ~1.1.GB data in
> the source directory. make install tried to copy theses 1.1GB to
> /local/samba-3.0.12 which ended in a full /local filesytem. I can reproduce this
> behavior with debian testing too.

(In reply to comment #0)
> After the make run, binaries are not stripped. This results in ~1.1.GB data in
> the source directory. make install tried to copy theses 1.1GB to
> /local/samba-3.0.12 which ended in a full /local filesytem. I can reproduce this
> behavior with debian testing too.

(In reply to comment #1)
> what compiler (and version) and what configure flags are you using?

On Solaris (gcc version 2.95.2) just I ran
./configure --with-acl-support --prefix=/usr/local/samba3012
--with-quotas --with-ssl --with-included-popt

These are the same options I used the last x upates.

On Debian (gcc-Version 3.3.5) only ./configure - nothing special. 

I will upload the config.log from the solaris system.
Comment 3 Ralf Gross 2005-03-22 09:39:10 UTC
Created attachment 1062 [details]
config.log (solaris)
Comment 4 Gerald (Jerry) Carter 2005-03-22 09:52:36 UTC
Ralf, Looks like the default CFLAGS setting is "-g -O2" if 
nothing has been set explicitly.  You can override the
by setting

   env CFLAGS="-O2" ./configure .....

This is a temporary fix for now.  The long term fix is to
call either install or install-strip based on whether  
the --enable-debug configure option has been defined.
I'll work on this later.
Comment 5 Ralf Gross 2005-03-22 09:56:50 UTC
(In reply to comment #4)
> Ralf, Looks like the default CFLAGS setting is "-g -O2" if 
> nothing has been set explicitly.  You can override the
> by setting
> 
>    env CFLAGS="-O2" ./configure .....
> 
> This is a temporary fix for now.  The long term fix is to
> call either install or install-strip based on whether  
> the --enable-debug configure option has been defined.
> I'll work on this later.


Fine, I'll give it a try. Thanks!
Comment 6 Gerald (Jerry) Carter 2006-01-17 21:17:09 UTC
closing since we have a workaround