Bug 2491 - rsync fails SILENTLY uploading file to non-existant directory via daemon
rsync fails SILENTLY uploading file to non-existant directory via daemon
Status: CLOSED FIXED
Product: rsync
Classification: Unclassified
Component: core
2.6.2
x86 Linux
: P3 critical
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 17:56 UTC by brad
Modified: 2005-04-01 11:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brad 2005-03-18 17:56:57 UTC
I can reproduce this reliably.

if module FOO maps to /tmp/foo/, which is empty, and client uploads with:

rsync foo rsync://HOST/FOO/nonexistantdir/foo

client exists success, but no file is there. This works as expected over SSH,
message is recieved indicating that no directory exists, and exit code is non zero.

Sorry if this is a duplicate, I searched and found nothing...

Please email for clarification if needed.
Comment 1 Wayne Davison 2005-03-18 19:32:33 UTC
This is a function of whether the server returns errors to the client or just
logs them locally, and 2.6.3 is not one of the servers that kept errors to
itself, so I changed the version of this bug to 2.6.2.  Your server might also
be 2.5.7 or before -- the bug was around a very long time.

Anyway, this has been fixed since the release of 2.6.3, and it is still fixed in
2.6.4 (which is in the final stages of its pre-release testing).