Bug 2445 - [patch] AIX ACLs are incorrect when displayed in Windows XP
[patch] AIX ACLs are incorrect when displayed in Windows XP
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.11
Other Windows XP
: P3 major
: none
Assigned To: William Jojo
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 09:06 UTC by William Jojo
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Attachments
Add debug class for ACLs into sysacls.c and fix DEFAULT acl in AIX. (583 bytes, patch)
2005-03-14 09:13 UTC, William Jojo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Jojo 2005-03-14 09:06:39 UTC
The first entry on a directory is lost in Access and Default ACL 
reconciliation. The problem is AIX does not have a DEFAULT classification.
Comment 1 William Jojo 2005-03-14 09:13:19 UTC
Created attachment 1030 [details]
Add debug class for ACLs into sysacls.c and fix DEFAULT acl in AIX.
Comment 2 Jeremy Allison 2005-03-14 13:03:30 UTC
Applied, thanks !
Jeremy.
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:24:50 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.