Bug 2441 - primary group membership lost when using "force group"
primary group membership lost when using "force group"
Status: RESOLVED DUPLICATE of bug 3990
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 FreeBSD
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-03-12 03:58 UTC by Matej Ondrusek
Modified: 2009-01-25 13:49 UTC (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Matej Ondrusek 2005-03-12 03:58:27 UTC
If I use parameter

force group="some_group"

in smb.conf, primary group of connected user (specified in /etc/passwd) is no
more used for file access checks. This is different behaviour from previous
versions of Samba (including 3.0.10) which makes some configurations unusable.

Tested on FreeBSD 4.11 & Samba 3.0.11. If Samba is reverted to 3.0.10 on the
same system, it works right.
Comment 1 deVas 2005-06-06 03:16:46 UTC
(In reply to comment #0)
Same for me: Linux 2.4.27-ct-1 (Debian) and Samba 3.0.14a-Debian
; makes my configuration unusable, possible workaround makes me headaches.

Comment 2 Volker Lendecke 2006-04-09 12:14:01 UTC
The manpage for 'force group' says:

This specifies a UNIX group name that will be assigned as the default primary group for all users connecting to this service.

So this behaviour is by design. Diff'ed 3.0.10 and 3.0.11, and I did not find any reason why the behaviour changed.

What was the behaviour you have seen in 3.0.10?


Comment 3 Matej Ondrusek 2006-04-10 01:59:15 UTC
> What was the behaviour you have seen in 3.0.10?

Look on this example:

(part of) /etc/passwd:

(part of) /etc/group:

(part of) ls -ld /data/testfolder
drwxrwx---  19 root  joe  512 May 18  2004 /data/testfolder

If I have share with 


and I set 

force group=groupa

I cannot access testfolder logged in as user joe. Before the change it was possible because group "joe" is primary group of user "joe" specified in /etc/passwd and this group membership was not lost even when the primary group was set with "force group" to something diferrent (probably samba moved previous  primary group to additional group list of the process, but it's only my opinion).
Comment 4 Volker Lendecke 2006-04-11 02:29:25 UTC
Can you send me a debug level 10 log of your 3.0.10 installation's smbd doing this? I can't reproduce it here.

Comment 5 Timur Bakeyev 2007-06-03 06:22:17 UTC
This bug looks like the same to the one in https://bugzilla.samba.org/show_bug.cgi?id=3990

Please, try latest 3.0.25a version of Samba to see if this problem is fixed.

With best regards,
Comment 6 Volker Lendecke 2009-01-25 13:49:12 UTC

*** This bug has been marked as a duplicate of 3990 ***