Bug 241 - windows 2k APW CUPS change defaut driver
windows 2k APW CUPS change defaut driver
Status: RESOLVED LATER
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.0preX
All Linux
: P4 normal
: 3.0.1
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-21 01:11 UTC by Jiri Franek
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Franek 2003-07-21 01:11:21 UTC
Printing CUPS, Samba as ADS domain member (W2k SP3+)
if i try to change Samba printer driver from W2k box i got this message, but 
driver change and samba continues operations normaly

[2003/07/21 10:03:17, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 25349 (3.0.0beta2)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/07/21 10:03:17, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/07/21 10:03:17, 0] lib/util.c:smb_panic(1462)
  PANIC: internal error
[2003/07/21 10:03:17, 0] lib/util.c:smb_panic(1469)
  BACKTRACE: 32 stack frames:
   #0 /usr/local/samba/sbin/smbd(smb_panic+0x16c) [0x818c0fc]
   #1 /usr/local/samba/sbin/smbd(dbgtext+0x193) [0x817b993]
   #2 /usr/local/samba/sbin/smbd(dbgtext+0x1f2) [0x817b9f2]
   #3 /lib/libc.so.6(__libc_sigaction+0x138) [0x402997f8]
   #4 /lib/libc.so.6(__libc_realloc+0x51b) [0x402e01cb]
   #5 /lib/libc.so.6(__libc_realloc+0x224) [0x402dfed4]
   #6 /usr/local/samba/sbin/smbd(Realloc+0x7a) [0x818b74a]
   #7 /usr/local/samba/sbin/smbd(unpack_devicemode+0x223) [0x81a8133]
   #8 /usr/local/samba/sbin/smbd(get_printer_data+0x1cb) [0x81a999b]
   #9 /usr/local/samba/sbin/smbd(get_printer_data+0xc37) [0x81aa407]
   #10 /usr/local/samba/sbin/smbd(get_a_printer+0x197) [0x81ab6b7]
   #11 /usr/local/samba/sbin/smbd(construct_info_data+0x108) [0x8102488]
   #12 /usr/local/samba/sbin/smbd(construct_info_data+0x5f7) [0x8102977]
   #13 /usr/local/samba/sbin/smbd(_spoolss_rfnpcnex+0x194) [0x8102dc4]
   #14 /usr/local/samba/sbin/smbd(_srv_net_name_validate+0xbf7) [0x80f9147]
   #15 /usr/local/samba/sbin/smbd(api_rpcTNP+0x224) [0x8125d14]
   #16 /usr/local/samba/sbin/smbd(api_pipe_request+0x13b) [0x81259ab]
   #17 /usr/local/samba/sbin/smbd(free_pipe_context+0x4b0) [0x8120170]
   #18 /usr/local/samba/sbin/smbd(free_pipe_context+0x69f) [0x812035f]
   #19 /usr/local/samba/sbin/smbd(free_pipe_context+0x909) [0x81205c9]
   #20 /usr/local/samba/sbin/smbd(write_to_pipe+0x15f) [0x812078f]
   #21 /usr/local/samba/sbin/smbd(write_to_pipe+0xdb) [0x812070b]
   #22 /usr/local/samba/sbin/smbd(send_trans_reply+0x731) [0x8087fa1]
   #23 /usr/local/samba/sbin/smbd(send_trans_reply+0x94c) [0x80881bc]
   #24 /usr/local/samba/sbin/smbd(reply_trans+0x980) [0x8088ba0]
   #25 /usr/local/samba/sbin/smbd
(respond_to_all_remaining_local_messages+0x68f) [0x80ba19f]
   #26 /usr/local/samba/sbin/smbd
(respond_to_all_remaining_local_messages+0x730) [0x80ba240]
   #27 /usr/local/samba/sbin/smbd(process_smb+0x18e) [0x80ba4fe]
   #28 /usr/local/samba/sbin/smbd(smbd_process+0x1b3) [0x80baea3]
   #29 /usr/local/samba/sbin/smbd(main+0x6cf) [0x81e899f]
   #30 /lib/libc.so.6(__libc_start_main+0xbe) [0x402887ee]
   #31 /usr/local/samba/sbin/smbd(_start+0x21) [0x8076511]
Comment 1 Gerald (Jerry) Carter 2003-07-25 13:37:11 UTC
I made a few smalls changes and my tests show ok against the latest
3.0 CVS code.

please test out the latest CVS code and let me know how it goes.
Comment 2 Gerald (Jerry) Carter 2003-08-19 19:54:42 UTC
no feedback.  Please reopen if you can reproduce 
against 3.0.0RC1.
Comment 3 Jiri Franek 2003-09-08 03:57:41 UTC
Jerry, sorry for delay (hollidays),my try against RC1, krb 1.3.1, my next try 
will be RC2
--------------------------------------------------------------------------------
[2003/09/08 12:51:32, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 18667 (3.0.0rc1)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/09/08 12:51:32, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/09/08 12:51:32, 0] lib/util.c:smb_panic(1462)
  PANIC: internal error
[2003/09/08 12:51:32, 0] lib/util.c:smb_panic(1469)
  BACKTRACE: 30 stack frames:
   #0 /usr/local/samba/sbin/smbd(smb_panic+0x16c) [0x818f0dc]
   #1 /usr/local/samba/sbin/smbd(dbgtext+0x193) [0x817eb63]
   #2 /usr/local/samba/sbin/smbd(dbgtext+0x1f2) [0x817ebc2]
   #3 /lib/libc.so.6(__libc_sigaction+0x138) [0x402997f8]
   #4 /lib/libc.so.6(malloc+0xe4) [0x402def64]
   #5 /usr/local/samba/sbin/smbd(tdb_unpack+0x1c5) [0x81a2065]
   #6 /usr/local/samba/sbin/smbd(get_printer_data+0xf8) [0x81aeb38]
   #7 /usr/local/samba/sbin/smbd(get_printer_data+0xc37) [0x81af677]
   #8 /usr/local/samba/sbin/smbd(get_a_printer+0x1b7) [0x81b0947]
   #9 /usr/local/samba/sbin/smbd(construct_info_data+0x108) [0x81052e8]
   #10 /usr/local/samba/sbin/smbd(construct_info_data+0x5f7) [0x81057d7]
   #11 /usr/local/samba/sbin/smbd(_spoolss_rfnpcnex+0x194) [0x8105c24]
   #12 /usr/local/samba/sbin/smbd(_srv_net_name_validate+0xbf7) [0x80fbdc7]
   #13 /usr/local/samba/sbin/smbd(api_rpcTNP+0x224) [0x8128e54]
   #14 /usr/local/samba/sbin/smbd(api_pipe_request+0xd0) [0x8128ba0]
   #15 /usr/local/samba/sbin/smbd(free_pipe_context+0x4b0) [0x8123210]
   #16 /usr/local/samba/sbin/smbd(free_pipe_context+0x69f) [0x81233ff]
   #17 /usr/local/samba/sbin/smbd(free_pipe_context+0x909) [0x8123669]
   #18 /usr/local/samba/sbin/smbd(write_to_pipe+0x15f) [0x812382f]
   #19 /usr/local/samba/sbin/smbd(write_to_pipe+0xdb) [0x81237ab]
   #20 /usr/local/samba/sbin/smbd(send_trans_reply+0x731) [0x80889d1]
   #21 /usr/local/samba/sbin/smbd(send_trans_reply+0x94c) [0x8088bec]
   #22 /usr/local/samba/sbin/smbd(reply_trans+0x998) [0x80895e8]
   #23 /usr/local/samba/sbin/smbd
(respond_to_all_remaining_local_messages+0x68f) [0x80bc7df]
   #24 /usr/local/samba/sbin/smbd
(respond_to_all_remaining_local_messages+0x730) [0x80bc880]
   #25 /usr/local/samba/sbin/smbd(process_smb+0x18e) [0x80bcb3e]
   #26 /usr/local/samba/sbin/smbd(smbd_process+0x1b3) [0x80bd523]
   #27 /usr/local/samba/sbin/smbd(main+0x69f) [0x81e9cdf]
   #28 /lib/libc.so.6(__libc_start_main+0xbe) [0x402887ee]
   #29 /usr/local/samba/sbin/smbd(_start+0x21) [0x8076e21]
[2003/09/08 12:51:32, 0] smbd/service.c:set_admin_user(314)
  franek logged in as admin user (root privileges)
--------------------------------------------------------------------------------
Comment 4 Gerald (Jerry) Carter 2003-11-13 21:10:21 UTC
please test against 3.0.1pre3.  Sorry for the 
long delay with no updates.  If you can still 
reproduce it, a gdb backtrace with symbols would 
be helpful (compile with --enable-debug).
Comment 5 Gerald (Jerry) Carter 2003-11-21 21:18:42 UTC
lower priority until i find out if it can still be reproduced 
against 3.0.1pre3
Comment 6 Gerald (Jerry) Carter 2003-12-07 21:33:53 UTC
closing since there has been no feedback for almost a month.
Please reopen if you find the bug stil exists in 3.0.1rc1
Comment 7 Gerald (Jerry) Carter 2005-02-07 09:04:49 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 8 Gerald (Jerry) Carter 2005-11-14 09:24:08 UTC
database cleanup