Bug 2407 - disabling of printer queues not reported to client
disabling of printer queues not reported to client
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.11
Other HP-UX
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-02 02:42 UTC by Torsten Werner
Modified: 2005-03-08 12:23 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Werner 2005-03-02 02:42:44 UTC
Do the following at a client:
- right click at a printer, choose "Pause Prining"
- the printer will be disabled at UNIX, but the context menu will be leaved
untouched.
- there is now chance to enable the printer from client. 

I did not found the place in the source code where samba looks for the printer
state to keep the client informed. When you give me a hint which function tries
to detect the printer status I can try to fix it. 

The bug exists as long as I know Samba. In the past I had a own shell script
which disables a enabled printer and enables a disabled printer. Then I sent a
message by smbclient in this script. But on XP SP2 the messanger is disabled by
default and so I hav no chance to send a response.
Comment 1 Torsten Werner 2005-03-03 10:40:31 UTC
I found a solution with a configuration change. With option
lpq command = lpstat -o%p -p%p 
it seems to work in generally. Two minor problems:
- After the procedure descripted to reproduce the problem a new printer without
name appears
- The printer on windows is updated after hit <F5> button, not automatically.
My test system is very slow. it could be that I run in a time out. But I don't
believe it because the reaction on <F5> needs less then a second.
Comment 2 Gerald (Jerry) Carter 2005-03-07 15:57:35 UTC
what client are you using for testing (OS and service pack) ?
The automatic notify works fine here.
Comment 3 Gerald (Jerry) Carter 2005-03-08 12:23:41 UTC
I've been over this some.  The change notify works fine locally.
It should probably be noted that WinXP SP2 completely broke 
MS's print change notify functionality.  EVen Windows to Windows.
Not much I've found that we can do about that currently.