Bug 2405 - print support for hpux broken
Summary: print support for hpux broken
Status: CLOSED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Printing (show other bugs)
Version: 3.0.11
Hardware: Other HP-UX
: P3 regression
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-02 01:48 UTC by Torsten Werner
Modified: 2005-08-24 10:20 UTC (History)
0 users

See Also:


Attachments
Patch for source/printing/pcap.c (65 bytes, patch)
2005-03-02 01:55 UTC, Torsten Werner
no flags Details
Apply this patch to source/printing/print_svid.c.patch (61 bytes, patch)
2005-03-02 01:57 UTC, Torsten Werner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Werner 2005-03-02 01:48:30 UTC
Symptom: samba tries to open a file 'lpstat' to read printers if hpux defined as
printing system. 

The problem is, that the special handling is defined for SYSV, but not for HPUX.
The solution is very simple and I've a patch for that. I'll send it as mail to
jerry@samba.org
Comment 1 Torsten Werner 2005-03-02 01:55:06 UTC
Created attachment 1000 [details]
Patch for source/printing/pcap.c

Apply this patch to 3.0.11 source/printing/pcap.c
It will replace a line with a #ifdef statement
Comment 2 Torsten Werner 2005-03-02 01:57:36 UTC
Created attachment 1001 [details]
Apply this patch to source/printing/print_svid.c.patch

Apply the patch to 3.0.11
It will replace a line with a #ifdef statement
Comment 3 Gerald (Jerry) Carter 2005-03-07 15:09:24 UTC
patch applied
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:20:04 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.