Bug 2394 - Unresolved text symbol "become_root"
Unresolved text symbol "become_root"
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.11
SGI IRIX
: P1 regression
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-26 20:03 UTC by g.fischer@ah-online.com
Modified: 2005-08-24 10:15 UTC (History)
1 user (show)

See Also:


Attachments
add DUMMYROOT_OBJ to nmbd (601 bytes, patch)
2005-02-28 10:12 UTC, Gerald (Jerry) Carter
no flags Details
full patch for makefile (5.64 KB, patch)
2005-02-28 12:17 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description g.fischer@ah-online.com 2005-02-26 20:03:29 UTC
samba-3.0.12pre1, irix 6.5.27, mipspro 7.42.
all prior versions worked very well!!

used: ./configure --prefix=/usr/samba

Using FLAGS =  -O3 -mips4 -OPT:IEEE_arithmetic=3 -lfastm -lm  -Iinclude
-I/temp/samba-3.0.12pre1/source/include -I/temp/samba-3.0.12pre1/source/ubiqx
-I/temp/samba-3.0.12pre1/source/smbwrapper  -I. -I/usr/local/include
-I/usr/local2/include -I/usr/nekoware/include -I/temp/samba-3.0.12pre1/source    
      LIBS = -lgen -lexc -liconv
      LDSHFLAGS = -set_version sgi1.0 -shared  -L/usr/local/lib
-L/usr/local2/lib -L/usr/nekoware/lib -L/usr/lib32
      LDFLAGS = -L/usr/local/lib -L/usr/local2/lib -L/usr/nekoware/lib -L/usr/lib32
Linking bin/nmbd
ld32: WARNING 84 : /usr/lib32/libfastm.so is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libgen.so is not used for resolving any symbol.
ld32: ERROR   33 : Unresolved text symbol "become_root" -- 1st referenced by
lib/util.o.
        Use linker option -v to see when and which objects, archives and dsos
are loaded.  
ld32: INFO    152: Output file removed because of error.
gmake: *** [bin/nmbd] Error 2
Comment 1 Gerald (Jerry) Carter 2005-02-28 10:12:44 UTC
Created attachment 994 [details]
add DUMMYROOT_OBJ to nmbd
Comment 2 Gerald (Jerry) Carter 2005-02-28 10:13:11 UTC
James, since this was originally your change, could you double 
check this fix for me ?  Thanks.
Comment 3 g.fischer@ah-online.com 2005-02-28 11:12:25 UTC
sorry, patch doesn't work.

Using FLAGS =  -O3 -mips4 -OPT:IEEE_arithmetic=3 -lfastm -lm  -Iinclude
-I/temp/samba-3.0.12pre1/source/include -I/temp/samba-3.0.12pre1/source/ubiqx
-I/temp/samba-3.0.12pre1/source/smbwrapper  -I. -I/usr/local/include
-I/usr/local2/include -I/usr/nekoware/include -I/temp/samba-3.0.12pre1/source    
      LIBS = -lgen -lexc -liconv
      LDSHFLAGS = -set_version sgi1.0 -shared  -L/usr/local/lib
-L/usr/local2/lib -L/usr/nekoware/lib -L/usr/lib32
      LDFLAGS = -L/usr/local/lib -L/usr/local2/lib -L/usr/nekoware/lib -L/usr/lib32
Linking bin/smbclient
ld32: WARNING 84 : /usr/lib32/libfastm.so is not used for resolving any symbol.
ld32: WARNING 84 : /usr/lib32/libgen.so is not used for resolving any symbol.
ld32: ERROR   33 : Unresolved text symbol "become_root" -- 1st referenced by
lib/util.o.
        Use linker option -v to see when and which objects, archives and dsos
are loaded.  
ld32: INFO    152: Output file removed because of error.
gmake: *** [bin/smbclient] Error 2
Comment 4 Gerald (Jerry) Carter 2005-02-28 12:17:40 UTC
Created attachment 995 [details]
full patch for makefile
Comment 5 Gerald (Jerry) Carter 2005-02-28 12:19:41 UTC
ok.  'make everything' finishes successfuly for me now.  SHould 
be really fixed this time.  SOrry about the previous bad patch.
Comment 6 g.fischer@ah-online.com 2005-02-28 12:46:34 UTC
works perfectly ;-)

thanks!!
Comment 7 James Peach (outdated mail address) 2005-02-28 14:50:05 UTC
(In reply to comment #1)
> Created an attachment (id=994) [edit]
> add DUMMYROOT_OBJ to nmbd

I had a patch which added the dummy stub to LIB_NONSMBD_OBJ, but whatever
works. I thought I had posted it, but apparantly not ..sorry.
Comment 8 Gerald (Jerry) Carter 2005-02-28 15:04:10 UTC
James, that was what I eventually did.  You might have included the
patch to Makefile.in originally but it just got lost in the noise.
no biggie.  everything's cool now.
Comment 9 Gerald (Jerry) Carter 2005-08-24 10:15:31 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.