Bug 2371 - Hostnames over 16 characters fail even when nmbd is not needed
Hostnames over 16 characters fail even when nmbd is not needed
Status: RESOLVED DUPLICATE of bug 3659
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.11
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 11:50 UTC by Thomas Boutell
Modified: 2006-04-14 15:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Boutell 2005-02-21 11:50:52 UTC
[Category is a stab in the dark]

After much wailing and gnashing of teeth, I determined that the reason for
persistent STATUS_BUFER_OVERFLOW errors was simple: the name of the host (just
the "short name," everything prior to the first dot) was longer than 16 characters.

Since this machine was to be part of an Active Directory domain in an
all-win2k-or-later environment, there was no use of NetBIOS name resolution and
so no legitimate reason for a 16-character limit that I am aware of.

I finally figured it out because log.nmbd contained complaints about the long
name at startup. Since I wasn't actually using netbios name resolution I could
just as easily have never caught this one.

A more enlightening error message, and a warning about long names in the HOWTO,
would go a long way if eliminating 16-character-limit assumptions in the code is
not practical in the 3.0 series.

Thanks.
Comment 1 Gerald (Jerry) Carter 2005-09-28 07:30:24 UTC
STATUS_BUFER_OVERFLOW is a normal RPC error code when the PDU is 
fragmented across multiple packets.  That's not a real error.
What is *not* working in your environment?
Comment 2 Gerald (Jerry) Carter 2006-04-14 15:01:06 UTC

*** This bug has been marked as a duplicate of 3659 ***