Bug 2366 - nmbd crashs with INTERNAL ERROR when binding to tun0
nmbd crashs with INTERNAL ERROR when binding to tun0
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.10
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 02:24 UTC by Andrew
Modified: 2006-01-17 08:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2005-02-21 02:24:57 UTC
After an OpenVPN tunnel is established (with 0 or N OpenVPN clients connected),
starting samba (service smb start) results in nmbd crashing. The log file only
provides:

[2005/02/21 18:49:36, 0] nmbd/nmbd.c:main(668)
  Netbios nameserver version 3.0.10 started.
  Copyright Andrew Tridgell and the Samba Team 1994-2004
[2005/02/21 18:49:37, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2005/02/21 18:49:37, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 8658 (3.0.10)
  Please read the appendix Bugs of the Samba HOWTO collection
[2005/02/21 18:49:37, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2005/02/21 18:49:37, 0] lib/util.c:smb_panic2(1482)
  PANIC: internal error
[2005/02/21 18:49:37, 0] lib/util.c:smb_panic2(1490)
  BACKTRACE: 2 stack frames:
   #0 nmbd(smb_panic2+0xdb) [0x80c73cb]
   #1 [0x494c0002]


If the "interfaces" line in the smb.conf file is changed to eth0 or similar, the
service functions as normal. The interfaces line reads:

interfaces = tun0 127.0.0.1 

I have also tried (192.168.15.0/24 is the VPN subnet):

interfaces = 192.168.15.1 127.0.0.1

Just FYI, the reason I am doing this is that I want VPN clients to be able to
browse the domain so the server is acting as a local master for the VPN subnet.

Any help would be great.

Andrew
Comment 1 Andrew 2005-02-21 08:10:40 UTC
Of course, tun0 is a /32 interface and so is not broadcastable which is probably
causing nmbd to fail.

Andrew
Comment 2 Jeremy Allison 2005-02-21 11:51:38 UTC
What we need is a complete stack backtrace. nmbd compiled with -g and the
run it under gdb. Once it has crashed type "bt" to print out the backtrace
containing line numbers.
Thanks,
Jeremy.
Comment 3 Fabio Muzzi Frabetti 2005-05-10 07:18:58 UTC
I seem to have a similar issue. After having installed openvpn I have added tun1
to samba interfaces list, and my nmbd (tried 3.0.13 and 14a) sometimes locks up.
I have found about it because clients connecting to the domain cannot find the
PDC (I get an error 1355 from win2000) until I kill nmbd and restart it. Nothing
is written to the logs, the process remains apparently running and must be
killed -9 to stop it. After restarting, nmbd seems to answer queries for some
time (not sure if minutes or hours) and then hangs again and stops answering
queries.
Comment 4 Jeremy Allison 2005-05-10 09:42:17 UTC
Adding "me too" to the bug report won't help us fix it.

I say again. what we need is a complete stack backtrace. nmbd compiled with -g
and the
run it under gdb. Once it has crashed type "bt" to print out the backtrace
containing line numbers.
Thanks.
Jeremy.
Comment 5 Fabio Muzzi Frabetti 2005-05-11 04:42:23 UTC
Sorry for not being helpful, but it seems I was misleaded. My nmbd keeps haging
(not crashing) even after removing tun1 from the interfaces, so my issue is
definitely not the same that was discussed here. I'll make some other tests and
report back if this behaviuor is really a bug and not caused by something wrong
in my server (maybe a corrupted database?). It's not so easy for me to recompile
nmbd because I'm using the packaged (Debian) binary version of Samba and I don't
have everything set up to compile by myself. Also, the fact that it hangs after
some hours running makes it harder to debug.
Comment 6 Gerald (Jerry) Carter 2006-01-17 08:09:51 UTC
please retest against 3.0.21a.  THere have been some 
nmbd crashes fixed since 3.0.10