Bug 2329 - error with "disable netbios = yes"
error with "disable netbios = yes"
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.11
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-09 10:34 UTC by Marco D'Ettorre
Modified: 2005-08-24 10:25 UTC (History)
2 users (show)

See Also:


Attachments
winbind.log (3.45 KB, application/gz)
2005-02-09 10:35 UTC, Marco D'Ettorre
no flags Details
patch to fix winbindd when no netbios support is enabled (6.04 KB, patch)
2005-02-10 15:50 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco D'Ettorre 2005-02-09 10:34:39 UTC
Hello,

when upgrade to 3.0.11 (from 3.0.9), I get the following error: 
[root@server-c02 samba]# wbinfo -a domain\\user%password
plaintext password authentication failed
error code was NT_STATUS_NO_LOGON_SERVERS (0xc000005e)
error messsage was: No logon servers
Could not authenticate user domain\user%password with plaintext password
challenge/response password authentication failed
error code was NT_STATUS_NO_LOGON_SERVERS (0xc000005e)
error messsage was: No logon servers
Could not authenticate user domain\user with challenge/response

Before the upgrade the same command worked fine:
[root@server-c02 samba]# wbinfo -a domain\\user%password
plaintext password authentication succeeded
challenge/response password authentication succeeded

In order to work fine again, I have to comment a few lines in my smb.conf:
#        disable netbios = Yes
#        nt pipe support = No
#        nt status support = No


This is my smb.conf (working fine with samba-3.0.9)
        interfaces = lo
                                                                               
                   log level = 1
                                                                               
                   workgroup = FILPP
                                                                               
                   disable netbios = Yes
        nt pipe support = No
        nt status support = No
        security = ads
        encrypt passwords = Yes
        realm = FILPP.INBCPP.IT
        password server = *
        wins server = FILPP.INBCPP.IT
                                                                               
                   winbind uid = 10000-60000
        winbind gid = 10000-60000
        winbind enum users = no
        winbind enum groups = no
        winbind use default domain = Yes
        winbind cache time = 86400
                                                                               
                   lanman auth = no
        ntlm auth = no
        client NTLMv2 auth = yes
        client lanman auth = no
        client plaintext auth = no
                                                                               
                   client signing = yes
        client use spnego = no
        socket options = TCP_NODELAY




Regards
Marco
Comment 1 Marco D'Ettorre 2005-02-09 10:35:48 UTC
Created attachment 959 [details]
winbind.log

Attached there are windbind.log files (level=3):
   ko.log: don't work
   ok.log: work
both files contains log while doing the following operations:
   service winbind start
   wbinfo -a domain\\user%password
Comment 2 Gerald (Jerry) Carter 2005-02-09 10:57:19 UTC
volkker,  I think this one is yours due to the change
in winbindd to always toa node status request for the 
DC name.  I could be wrong though.  Mind taking a look.
I'll try to ass well when I can find time.
Comment 3 Gerald (Jerry) Carter 2005-02-10 10:02:52 UTC
reproduced.  Working on a fix.
Comment 4 Gerald (Jerry) Carter 2005-02-10 15:50:17 UTC
Created attachment 961 [details]
patch to fix winbindd when no netbios support is enabled

please test this prelimary patch.  I'm not checking it in yet.
Just need to know if it fixes the bug for you.	It tests out fine 
locally.

You will need to run 'make proto; make' after applying it.
Thanks.
Comment 5 Gerald (Jerry) Carter 2005-02-10 15:50:49 UTC
adding volker to CC list.  You probably want to look at the patch.  I 
know it's a little dirty.  
Comment 6 Gerald (Jerry) Carter 2005-02-11 07:15:40 UTC
I've cleaned up the patch and run it through more tests.
I'm going to check it in and mark this as fixed.
I'll also update the latest patch at 
http://www.samba.org/~jerry/patches/post-3.0.11/
Comment 7 Gerald (Jerry) Carter 2005-08-24 10:25:12 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.