Bug 2325 - Problem with login "user@domain" and username.map
Problem with login "user@domain" and username.map
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.8
x86 All
: P3 major
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-08 07:41 UTC by Jorge Luis
Modified: 2005-02-09 08:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Luis 2005-02-08 07:41:26 UTC
When I have an user with the login "user@domain", the user can´t log on in the
domain. In the prior version of samba (3.0.7), we use username.map file to
mapping users like this:
jorge_mecon = jorge@mecon.
With the new versions (3.0.8 and above) I´ve the following log in the log.smbd file:

[2005/02/08 11:20:47, 0] auth/auth_util.c:make_server_info_info3(1134)
  make_server_info_info3: pdb_init_sam failed!

And the user can´t log on.

The solution that I found was copy  auth/auth_util.c file of the version 3.0.7
on the new version tree and re-compile samba, and work fine.

Thanks in advance
Comment 1 Gerald (Jerry) Carter 2005-02-08 13:45:04 UTC
I've tested this entry 

    jorge = jorge@mecon

Assuming that the Samba DC's domain is MECON.  It works fine in 
3.0.11.  
Comment 2 Lars Müller 2005-02-09 08:15:38 UTC
It also works if Samba is not the DC of domain if the mapped user ends with @domain.
Comment 3 Jorge Luis 2005-02-09 08:36:33 UTC
I tried with samba 3.0.11 but this version don´t fix the problem.
One thing:
My domain is called "SERVIDORES", and the user log on with "jorge@mecon" and I
translate it to jorge_mecon with the username.map.
The problem occurs in the File Server, not in the PDC.
I can resolve the problem with the following parameter:

security = SERVER instead of security = DOMAIN (this parameter I´ve set in
version 2.2.x and 3.0.7 and function without problems).

Thanks in advance 
Comment 4 Gerald (Jerry) Carter 2005-02-09 08:54:41 UTC
you can translate that to jorge_mecon but it means nothing.
security = domain performs the username mapping after 
authentication.  This is by design (see 3.0.8 release notes).

Closing this bug again as wont fix.  Sorry.