Bug 231 - Guest account in service section
Guest account in service section
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.0preX
All Solaris
: P2 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-16 06:02 UTC by Claude Frantz
Modified: 2007-04-29 14:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claude Frantz 2003-07-16 06:02:54 UTC
I have "guest account = nobody" in a share specific section of smb.conf. 
Testing with "testparm", I find the warning:
"Global parameter guest account found in service section!". When running smbd,
there is also a warning " param/loadparm.c:lp_do_parameter(3118)
  Global parameter guest account found in service section!   ". The man page
related to smb.conf says that "guest account" can be used in global and specific
sections. What is right ?
Comment 1 Andrew Bartlett 2003-07-20 04:01:36 UTC
Just confirming this was intentionally lost during Samba 3.0.

The semantics are hard to keep in the current design - if you want 'force user'
then use that, it remains 'per-share'.  (The problem is the changing meaning of
the guest account on ACLs, and the need to treat guest logins just like any
other user).
Comment 2 Gerald (Jerry) Carter 2003-07-23 05:46:05 UTC
XML source for man page updated
Comment 3 Gerald (Jerry) Carter 2005-02-07 08:40:06 UTC
originally reported against 3.0.0beta2.  CLeaning out 
non-production release versions.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:16:24 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:25:24 UTC
database cleanup
Comment 6 SPAMMER 2007-04-29 14:16:43 UTC
Created attachment 2564


adjustable shelving