Bug 2304 - WINS server unable to be Domain Master Browser
WINS server unable to be Domain Master Browser
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.8
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 09:25 UTC by Pedro Rebello de Andrade
Modified: 2005-02-04 13:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Rebello de Andrade 2005-02-03 09:25:45 UTC
Under (yet) undetermined contidions nmbd doesn't appear to be able to register 
itselt as domain master browser.
Apparently there is a problem with the UNICAST_SUBNET address which is wrongly 
assumed.
In the logs, with log level > 4 it reports something like UNICAST_SUBNET server 
UNKNOWN (and either the lo address or the eth0 address as broadcast address)
I've seen postings of this problem from as far as 2001 and since version 1.9.x.
The most common error users report is that a machine (usually WinNT,2k or XP) 
cannot join the domain stating that 'A domain controler for the domain cannot 
be contacted (...) error 0x0000232b'.

Equally, when this problem appears the server is unable to resolve addresses 
other than its own thru WINS, though wins.dat correctly registers all addresses.
The workgroup is invisible when browsing from any other workstation, and, 
reaching the shares through \\servername show a 'Unknown' named node where de 
workgroup name should be.

Can not yet tell how to replicate the problem.
Comment 1 Pedro Rebello de Andrade 2005-02-04 13:11:29 UTC
The problem was fixed, and it was not a samba bug, but, guess what... It was 
another fantastic 'undocumented feature' from MS(TM).

I happened to stumble with the cause of this behaviour. At least for the 
environment I was working with, the Windows machines, when having dhcp client 
enabled, are unable to contact correctly with the WINS server or the PDC 
through NetBIOS. Everything works fine if you give them fixed IP/DNS ip/WINS ip 
and disable -> 15 sec pause -> enable the network connection.

There is a minor issue with SAMBA tough, which should be documented by itself, 
possibly in a BUG report by itself:
The problem I reported in the end of the bug description <QUOTE> The workgroup 
is invisible when browsing from any other workstation, and, reaching the shares 
through \\servername show a 'Unknown' named node where the workgroup name 
should be. </END QUOTE> disappeared when I removed the line '127.0.0.1 
localhost' from the lmhosts file.