Bug 2303 - The description for "remote browse sync" parameter is not correct.
The description for "remote browse sync" parameter is not correct.
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Docs
3.0.10
x86 Linux
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba Documentation QA Contact~
http://lists.samba.org/archive/samba-...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 09:19 UTC by TAKAHASHI Motonobu
Modified: 2005-10-17 10:21 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TAKAHASHI Motonobu 2005-02-03 09:19:28 UTC
As I said http://lists.samba.org/archive/samba-technical/2005-
January/039067.html 
Currently the description for "remote browse sync" in smb.conf(5) is not 
correct than the real behavior of that parameter.

I think document update is needed...
Comment 1 John H Terpstra 2005-02-04 10:46:32 UTC
(In reply to comment #0) 
> As I said http://lists.samba.org/archive/samba-technical/2005- 
> January/039067.html  
> Currently the description for "remote browse sync" in smb.conf(5) is not  
> correct than the real behavior of that parameter. 
>  
> I think document update is needed... 
 
Please explain what is wrong and how is can be fixed. As a minimum, please 
explain how we can reproduce the problem. Thanks. 
Comment 2 TAKAHASHI Motonobu 2005-02-05 11:56:19 UTC
>> As I said http://lists.samba.org/archive/samba-technical/2005-
January/039067.html  
>>
>Please explain what is wrong and how is can be fixed. As a minimum, please 
>explain how we can reproduce the problem. Thanks. 

Is that not enough to explain what is wrong and how reproduce...
And please read the description for "remote browse sync" in smb.conf(5).

Currently the behavior is different from that described in smb.conf(5).
And I want to know if this difference happens because of miss-documentation or 
the implementation has been degraded.

-----
As far as I examined, "remote browse sync" parameter does not work as
described in smb.conf(5).

In addition to the description in smb.conf(5), 

1) both Samba box must be a **domain** master browse because they
  need to receive a Master Announcement.

2) both Samba box must be a WINS server because the workgroup name
 included in received Master Announcement packet must exists in
 UNICAST_SUBNET.

The following smb.conf is a minimum one to work remote browse sync
parameter.

-----
[global]
  workgroup = SAMBA01 (should be same atboth Samba box)
  domain master = Yes
  wins support = Yes
  remote browse sync = x.x.x.x (shoube be the other Samba box's IP)
  enhanced browsing = No (or Yes)
-----

At least this behavior differs from that in smb.conf(5). 
This behavior is by design or a bug? 

Umm, this parameter is really used ?
Comment 3 John H Terpstra 2005-04-25 22:31:05 UTC
(In reply to comment #2) 
 
> Currently the behavior is different from that described in smb.conf(5). 
> And I want to know if this difference happens because of miss-documentation > 
> or the implementation has been degraded. 
>  
> ----- 
> As far as I examined, "remote browse sync" parameter does not work as 
> described in smb.conf(5). 
>  
> In addition to the description in smb.conf(5),  
>  
> 1) both Samba box must be a **domain** master browse because they 
>   need to receive a Master Announcement. 
>  
> 2) both Samba box must be a WINS server because the workgroup name 
>  included in received Master Announcement packet must exists in 
>  UNICAST_SUBNET. 
>  
> The following smb.conf is a minimum one to work remote browse sync 
> parameter. 
>  
> ----- 
> [global] 
>   workgroup = SAMBA01 (should be same atboth Samba box) 
>   domain master = Yes 
>   wins support = Yes 
>   remote browse sync = x.x.x.x (shoube be the other Samba box's IP) 
>   enhanced browsing = No (or Yes) 
> ----- 
>  
> At least this behavior differs from that in smb.conf(5).  
> This behavior is by design or a bug?  
>  
> Umm, this parameter is really used ? 
 
I am finally getting back to the HOWTO documentation (including man pages). 
Apologies for the long delay.  
 
The remote browse parameter should work without a WINS server. It is not 
necessary to use the remote browse parameter when there is a central WINS 
server. 
 
I will check and update the man page. 
 
- John T. 
 
 
Comment 4 John H Terpstra 2005-10-17 10:21:12 UTC
I have added a notation to the smb.cnf man page entry for the remote browse sync
parameter.

Thanks for reporting this.

- John T.