Bug 2298 - smbclient queue issues printing to a 3.0.9 samba printer
smbclient queue issues printing to a 3.0.9 samba printer
Status: RESOLVED DUPLICATE of bug 1998
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
Sparc Solaris
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-02-02 05:04 UTC by Iván Couto
Modified: 2005-02-03 07:41 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Iván Couto 2005-02-02 05:04:37 UTC
I have set up a samba server in a Solaris 9 sparc host to become a file and 
printer server of my corporate network. Linux clients (debian sarge) use 
smbclient commands to print, get queues status and cancel jobs on the server. 
I have detected 2 major problems: 
1) When I get connected to the printer share via smbclient and I execute the 
"queue" command, the queue status is reported but jobid starts at 1,2...N 
With the same smbclient connection, if I type "queue" again jobids are the 
reported the first time*256! (job 1--->256, job 2--->512,...). This "feature" 
keep working on followins "queue" command.  If I want to cancel a job, I have 
to use the jobids reported the first time (1,2..) instead the jobid*256 
reported after the second queue query. 
2) With samba version 3.0.5 I'm able to cancel a job without problems, but 
with newer versions (3.0.6-3.0.9) the cancel command doesn't work at all!!.  
It just shows "job xx cancelled" but it doesn't really work as version 3.0.5.
Comment 1 Gerald (Jerry) Carter 2005-02-03 07:41:27 UTC

*** This bug has been marked as a duplicate of 1998 ***