Bug 2290 - Check for script/mkversion.sh and only call if available
Check for script/mkversion.sh and only call if available
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.10
All Linux
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-30 16:10 UTC by Lars Müller
Modified: 2005-08-24 10:27 UTC (History)
0 users

See Also:


Attachments
Test if we have an executeable mkversion.sh (531 bytes, patch)
2005-01-30 16:13 UTC, Lars Müller
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Müller 2005-01-30 16:10:38 UTC
Currently source/autogen.sh and examples/VFS/autogen.sh are the identical files.
 Jeremy aligned them.

This doesn't work for examles/VFS/autogen.sh as we don't have
script/mkversion.sh there.
Comment 1 Lars Müller 2005-01-30 16:13:07 UTC
Created attachment 927 [details]
Test if we have an executeable mkversion.sh

Test if we have an executeable mkversion.sh and only call it in this case.

If we apply this we could replace examples/VFS/autogen.sh by a sym link to
source/autogen.sh.
Comment 2 Gerald (Jerry) Carter 2005-01-31 06:16:18 UTC
I'm just going to make the change to the examples/VFS/autogen.sh script.
I think it will be ok to maintain the manually. 
Comment 3 Gerald (Jerry) Carter 2005-02-07 07:34:54 UTC
originally reported against 3.0.11pre1.  Moving back to version to 3.0.10 
to remove preX and rcX versions.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:27:41 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.