Bug 2279 - Modified date file on a share
Modified date file on a share
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.10
x86 Linux
: P3 major
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on: 3124
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-26 07:10 UTC by yann
Modified: 2013-09-02 12:25 UTC (History)
0 users

See Also:


Attachments
Test files (900 bytes, application/octet-stream)
2005-02-07 02:56 UTC, yann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description yann 2005-01-26 07:10:14 UTC
When i want synchonize disk file on a samba share , they are date problem.
When a windows is copy , created date and modified date change....

Exemple I have a windows file (on c:\) :
Created:  14.12.2004, 10:59:34
Modified: 25.01.2005, 19:10:51
Accessed: 26.01.2005, 13:55:57

When i  copy this file on a samba share :
Created:  25.01.2005, 19:10:52
Modified: 25.01.2005, 19:10:52
Accessed: 26.01.2005, 14:48:22


Created date, it not a problem for synchonize but
Modified change too .  19:10:51 --> 19:10:52

It's not fix, modified date change +/-  1s

It's not possible to synchronize disk on a samba share.

--------------------------
Client == Windows 2000
Server == Redhat  9.0
Comment 1 Jim McDonough 2005-01-30 20:33:07 UTC
Have you tried "dos filetimes = yes"
Comment 2 yann 2005-01-31 02:27:41 UTC
(In reply to comment #1)
> Have you tried "dos filetimes = yes"

Yes, i m tried. not success 
Comment 3 Gerald (Jerry) Carter 2005-02-03 07:42:51 UTC
betting this is fixed in 3.0.11 with jra Excel fixes for sticky mtimes.
Comment 4 yann 2005-02-07 02:56:45 UTC
Created attachment 951 [details]
Test files

list of file create on W2000 (french). Exemple:
file "1"  : Modified date monday 7 feb 2005 ,  10:47:44
after copy on samba share
file "1"  : Modified date monday 7 feb 2005 ,  10:47:45
Comment 5 yann 2005-02-07 03:02:27 UTC
Not resolved in 3.0.11
Comment 6 Gerald (Jerry) Carter 2005-02-07 06:26:06 UTC
Jeremy, Can you take a look at this?  It could be 
just the lack of high-res filetimes on UNIX.
Comment 7 yann 2005-11-02 13:05:25 UTC
Data are not replicate with all sync tools.
Comment 8 mike levine 2006-05-31 10:24:01 UTC
I am also seeing this on samba 3.0.14a.
Mod Times are off by one second when coping files from Windows to Samba share.
It is not occuring consistently, so it may have to do with rounding...
Comment 9 Björn Jacke 2013-09-02 12:25:10 UTC
pretty sure this is fixed since long. if you still see this issue, please reopen and give details about filesystem, kernel version etc. Thanks...