Bug 2254 - Access2000 files long delay if more than 1 user
Access2000 files long delay if more than 1 user
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.9
x86 Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-18 02:09 UTC by Peter Huetmannsberger
Modified: 2006-07-05 13:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Huetmannsberger 2005-01-18 02:09:25 UTC
Since upgrading to Samba-3.0.10 from 2.2.12 an ACCESS2000 database takes an
enormous amount of time to open for a second user. ( timed exactly 4 minutes ). 

Server Samba-3.0.10 on Linux RH9 (kernel-2.4.27)
Clients WinXP SP2 


First user can open normally, Second user tries to open (or even same user
again) and the cursor clock just keeps turning. After 4 minutes the file opens,
and is usable. Same thing occurs for a third user of the database. 

I have tried setting strict locking = no
oplocks = no
fake oplocks = yes
veto oplock files = *.\mdb 

and so on, but I have had no improvement. So I had to downgrade to 2.2.12 again. 

Stupidly the new install overwrote the old logfiles. If I can be of any help, I
would like to do that, I can produce some logfiles for you, if that would help.
If you do need my smb.conf as well, let me know, I will mail it a.s.a.p.

Anything you need to help tackle this issue, or any advice you have, I will try
to help, or test. Many thanks in advance.

Peter Huetmannsberger, RHCE
Comment 1 Peter Huetmannsberger 2005-01-25 12:09:57 UTC
I have since tried using samba-3.0.5 and it behaves exactly like the 2.x.x
Version  I had in use before. Something must have changed between 3.0.5 and 3.0.6. 

Interesting to watch was a tcpdump, which showed packets for about a second then
stopped for about a second then started up again. Meanwhile a watch smbstatus
showed files being locked and then they would disappear again, and then come
back again. All this for about 4 minuted, before it worked. 

If an ethereal dump of the network traffic helps, let me know. 

Comment 2 Gerald (Jerry) Carter 2006-07-05 13:06:24 UTC
please retest against 3.0.23.