Bug 2250 - WERR_BAD_PASSWORD when running cupsaddsmb as explained in chapter 19.
WERR_BAD_PASSWORD when running cupsaddsmb as explained in chapter 19.
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Docs
3.0.10
All Linux
: P3 normal
: none
Assigned To: Jelmer Vernooij
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-16 11:28 UTC by Trey Ethridge
Modified: 2005-08-24 10:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trey Ethridge 2005-01-16 11:28:17 UTC
Hey, I spent several hours trying to setup postscript printing using the
directions in chapter 19.  All was going well until I hit the step to run
cupsaddsmb.  The copying of the files worked, but when it tried to run the
"adddriver" commands, it would fail everytime with the error "result was
WERR_BAD_PASSWORD".  I finally found this blurb through google after much searching.

## setting cups samba drivers cupsaddsmb -a -v result was WERR_BAD_PASSWORD
download cups-samba-5.0rc3.tar.gz from http://www.cups.org Software|Cups Driver
for Windows, tar -xzvf , then run cups-samba.install
make sure you have security = user (NOT security = share) in smb.conf

I had security set to share, which was causing my problems.  Could you please
add a comment in the troubleshooting section.  I'd like to save some other
people the headache this issue caused me.  Keep up the good work.

Thanks,  
-- Trey
Comment 1 Jelmer Vernooij 2005-01-17 07:51:58 UTC
I've added a small block about it. Thanks!

Comment 2 Gerald (Jerry) Carter 2005-08-24 10:25:13 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.