Bug 2225 - Compilation errors in samba 3.0.10 on DGUX R4.20MU04 (aviion, data general)
Compilation errors in samba 3.0.10 on DGUX R4.20MU04 (aviion, data general)
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.9
Other All
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks: 2226
  Show dependency treegraph
 
Reported: 2005-01-07 08:08 UTC by Cord Hockemeyer
Modified: 2006-04-14 14:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cord Hockemeyer 2005-01-07 08:08:45 UTC
Dear Samba-Developers,

first of all a big THANK YOU for this product and for the certainly huge amount
of work and time you are spending on it!

Compiling samba 3.0.10 on a DGUX machine I got a number of compiler errors. If
possible, I would like a feedback if the corrections might cause problems (this
is my third or fourth attempt to get a samba v3 running on that maching in order
to be able to work with XP SP2 PCs).

- File smbd/vfs.c, line 889: the 'pstring' type specification for the first
parameter in the function call is obviously wrong. I have simply deleted it.
- File libsmb/clireadwrite.c, lines 54 and 301: The compiler warns that the
right shift count >= width of type (for offset). I have now typecasted it into
BIG_SMB_UINT.
- client/client.c: In line 699 and 1075 I get warnings that the fourth argument
(&size) is of incompatible pointer type (it is size_t and expected is
BIG_SMB_UINT). In line 2563 the PATH_MAX is undefined. I have now encapsulated
the two lines there into an '#ifdef PATH_MAX' directive.
- client/clitar.c, line 1487: Again, PATH_MAX is undefined. I have defiend it
here with a value of 512 which seems to be a POSIX minimum value.

Besides that there are about a warnings that 'const' or volatile' attributes of
variables are discarded in argument passing, returns, or assignments, and some
warning about incompatible pointer types. If you are interested in these, I
could certainly re-compile making a log of the make/gcc output.

Kind Regards,
  Cord Hockemeyer
Comment 1 Gerald (Jerry) Carter 2005-02-05 07:57:23 UTC
please retest against 3.0.11 since the changeset is rather large.  If all
of the issues have not been addressed, please reopen the bug report and 
reset the version.  Thanks.
Comment 2 Cord Hockemeyer 2005-04-20 14:00:50 UTC
All problems are still there in 3.0.14a.

Changed line numbers in the cource code:
- smbd/vfs.c: parse error in 897
- libsmb/clireadwrite: too large shift in 55 and 308
- client/client.c: Warnings in 767 and 1158; undefined PATH_MAX in 2922
- client/clitar.c: undefined PATH_MAX in 1476

The vfs.c bug seems to be exactly the one listed in bug report #2560.

Kind Regards,
  Cord Hockemeyer
Comment 3 Tim Potter 2005-04-20 18:47:11 UTC
Breaking dependcy on 2560 as it's fixed and I want to close it.
Comment 4 Gerald (Jerry) Carter 2006-04-14 14:54:16 UTC
Please retest against a current release and reopen if the issue is still present.