Bug 2216 - remote dies, local hangs when disk full
remote dies, local hangs when disk full
Status: CLOSED FIXED
Product: rsync
Classification: Unclassified
Component: core
2.6.3
All Linux
: P3 major
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 08:58 UTC by Baldvin Kovacs
Modified: 2005-04-01 11:22 UTC (History)
1 user (show)

See Also:


Attachments
The committed code for not hanging with -vvv (3.75 KB, patch)
2005-01-10 14:33 UTC, Wayne Davison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Baldvin Kovacs 2005-01-06 08:58:31 UTC
- I am running rsync through ssh
- In a certain phase, two processes exist on both sides
- Then, for example when there's a disk full on the remote (target) side, one of
the four processes dies, and all the others are hanging on forever (or until one
kills them :)
- I tried to reproduce it in a very small, one file environment, but I couldn't.
However, it happens reproducible for my real server...
- I'll continue to debug it, meanwhile I'd appreciate if anybody knowing the
problem would tell me what he/she knows about it (maybe helping to localize the
bug...)
Comment 1 Baldvin Kovacs 2005-01-06 10:33:46 UTC
I tried the cvs version: it works OK. However, 2.6.3 reproducably hangs.

In the NEWS:    - Fixed a potential hang when verbosity is high, the client side
               is the sender, and the file-list is large.

OK, maybe this is it. I checked cvs log, and cvs diff, but they are huge, and
I did not find the change corresponding to this very bugfix.

What I'd like to ask: will the release of 2.6.4 be very soon, and when, or
if it will not, could you please provide this bugfix as a patch so that
I could ask the debian maintainer to create a fixed package 2.6.3-3?

Thanks,
Baldvin
Comment 2 Wayne Davison 2005-01-10 14:33:28 UTC
Created attachment 882 [details]
The committed code for not hanging with -vvv

If you are using -vvv (or more) verbosity and the hang is occurring during the
initial transfer of the file list, this patch is what that was checked into CVS
to fix this.

If the hang is happening after the transfer starts, this patch will have no
effect on that.
Comment 3 Baldvin Kovacs 2005-01-13 08:13:16 UTC
Thank you very much for your answer! I did not reply for so long because I
thought I'll get an email from bugzilla. It turns out that I forgot to do my
homework in the bugzilla-settigs page!
Comment 4 Wayne Davison 2005-02-13 21:37:58 UTC
This appears to be fixed in the CVS version.