Bug 2215 - nmbd crashes with signal 11
nmbd crashes with signal 11
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.10
Sparc Linux
: P3 regression
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 07:13 UTC by Eric Cartman
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments
Patch suggested by gcc folks (811 bytes, patch)
2005-03-09 15:09 UTC, Jay Fenlason - please log in and update your mail address here and let us enable Bugmails to you again, Jay
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Cartman 2005-01-06 07:13:38 UTC
Debian 3.1 (testing) running on a sun ultra5 (sun4u sparc64)
with kernel 2.4.28...

after startup it runs half an hour then nmbd crash's with the following error:



[2005/01/06 14:41:14, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(173)
  find_workgroup_on_subnet: workgroup search for NETWORK on subnet 
UNICAST_SUBNET: 
===============================================================
[2005/01/06 14:41:14, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 15958 (3.0.10-Debian)
  Please read the appendix Bugs of the Samba HOWTO collection
[2005/01/06 14:41:14, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2005/01/06 14:41:14, 0] lib/util.c:smb_panic2(1472)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 15958]
[2005/01/06 14:41:16, 0] lib/util.c:smb_panic2(1480)
  smb_panic(): action returned status 0
[2005/01/06 14:41:16, 0] lib/util.c:smb_panic2(1482)
  PANIC: internal error
[2005/01/06 14:41:16, 0] lib/util.c:smb_panic2(1490)
  BACKTRACE: 2 stack frames:
   #0 /usr/sbin/nmbd [0xf6400]
   #1 [0x1846c8]
Comment 1 Jeremy Allison 2005-01-06 13:26:03 UTC
Can you compile with -g, then add a line to the smb.conf :

panic action = /bin/sleep 90000

Then when it crashes, attach to the parent of the sleep with
gdb and type "bt" for backtrace. Please attach the result of this to the bug report.

Thanks,

Jeremy.
Comment 2 Lorenzo Luconi Trombacchi 2005-01-12 03:57:45 UTC
Same problem with Fedora Core 3 and samba-3.0.10-1.fc3 (x86_64).
Some times nmbd stops responding but the process still running..

This is the trace when nmbd dies:

Jan 12 11:20:30 anakin nmbd[18598]: [2005/01/12 11:20:30, 0]
lib/fault.c:fault_report(36)
Jan 12 11:20:30 anakin nmbd[18598]:  
===============================================================
Jan 12 11:20:30 anakin nmbd[18598]: [2005/01/12 11:20:30, 0]
lib/fault.c:fault_report(37)
Jan 12 11:20:30 anakin nmbd[18598]:   INTERNAL ERROR: Signal 11 in pid 18598
(3.0.10-1.fc3)
Jan 12 11:20:30 anakin nmbd[18598]:   Please read the appendix Bugs of the Samba
HOWTO collection
Jan 12 11:20:30 anakin nmbd[18598]: [2005/01/12 11:20:30, 0]
lib/fault.c:fault_report(39)
Jan 12 11:20:30 anakin nmbd[18598]:  
===============================================================
Jan 12 11:20:30 anakin nmbd[18598]: [2005/01/12 11:20:30, 0]
lib/util.c:smb_panic2(1504)
Jan 12 11:20:30 anakin nmbd[18598]:   PANIC: internal error
Jan 12 11:20:30 anakin nmbd[18598]: [2005/01/12 11:20:30, 0]
lib/util.c:smb_panic2(1512)
Jan 12 11:20:30 anakin nmbd[18598]:   BACKTRACE: 12 stack frames:
Jan 12 11:20:30 anakin nmbd[18598]:    #0 nmbd(smb_panic2+0x6e) [0x552ab3d59e]
Jan 12 11:20:30 anakin nmbd[18598]:    #1 nmbd [0x552ab2b8a1]
Jan 12 11:20:30 anakin nmbd[18598]:    #2 /lib64/tls/libc.so.6 [0x2a962f9570]
Jan 12 11:20:30 anakin nmbd[18598]:    #3 nmbd [0x552aae680c]
Jan 12 11:20:30 anakin nmbd[18598]:    #4 nmbd [0x552ab272e9]
Jan 12 11:20:30 anakin nmbd[18598]:    #5 nmbd(ubi_sptFind+0x16) [0x552ab28106]
Jan 12 11:20:30 anakin nmbd[18598]:    #6 nmbd(find_name_on_subnet+0x37)
[0x552aadbda7]
Jan 12 11:20:30 anakin nmbd[18598]:    #7
nmbd(wins_process_name_query_request+0x8a) [0x552aae9dca]
Jan 12 11:20:30 anakin nmbd[18598]:    #8 nmbd(run_packet_queue+0xb6d)
[0x552aae19ed]
Jan 12 11:20:30 anakin nmbd[18598]:    #9 nmbd(main+0x3ea) [0x552aad36ea]
Jan 12 11:20:30 anakin nmbd[18598]:    #10
/lib64/tls/libc.so.6(__libc_start_main+0xea) [0x2a962e74ca]
Jan 12 11:20:30 anakin nmbd[18598]:    #11 nmbd [0x552aad232a]
Jan 12 11:20:30 anakin nmbd[18598]:




Lorenzo

> Debian 3.1 (testing) running on a sun ultra5 (sun4u sparc64)
> with kernel 2.4.28...
> 
> after startup it runs half an hour then nmbd crash's with the following error:
> 
> 
> 
> [2005/01/06 14:41:14, 4] nmbd/nmbd_workgroupdb.c:find_workgroup_on_subnet(173)
>   find_workgroup_on_subnet: workgroup search for NETWORK on subnet 
> UNICAST_SUBNET: 
> ===============================================================
> [2005/01/06 14:41:14, 0] lib/fault.c:fault_report(37)
>   INTERNAL ERROR: Signal 11 in pid 15958 (3.0.10-Debian)
>   Please read the appendix Bugs of the Samba HOWTO collection
> [2005/01/06 14:41:14, 0] lib/fault.c:fault_report(39)
>   ===============================================================
> [2005/01/06 14:41:14, 0] lib/util.c:smb_panic2(1472)
>   smb_panic(): calling panic action [/usr/share/samba/panic-action 15958]
> [2005/01/06 14:41:16, 0] lib/util.c:smb_panic2(1480)
>   smb_panic(): action returned status 0
> [2005/01/06 14:41:16, 0] lib/util.c:smb_panic2(1482)
>   PANIC: internal error
> [2005/01/06 14:41:16, 0] lib/util.c:smb_panic2(1490)
>   BACKTRACE: 2 stack frames:
>    #0 /usr/sbin/nmbd [0xf6400]
>    #1 [0x1846c8]

(In reply to comment #1)
> Can you compile with -g, then add a line to the smb.conf :
> 
> panic action = /bin/sleep 90000
> 
> Then when it crashes, attach to the parent of the sleep with
> gdb and type "bt" for backtrace. Please attach the result of this to the bug
report.
> 
> Thanks,
> 
> Jeremy.

Comment 3 Jeremy Allison 2005-01-12 16:48:08 UTC
Can you get a backtrace with nmbd compiled with -g please ? It would be really
helpful to get the core-dump file and the nmbd binary. I have fedora core 3 on
x86 and could look at this natively. But without symbols (-g) the backtrace is
not very useful.

Jeremy.
Comment 4 Lorenzo Luconi Trombacchi 2005-01-13 04:57:26 UTC
OK, but I'm using an rpm version of samba and I know how to create an rpm from a
src.rpm but I don't know how (and where) to add the -g option to spec file....
if you could give to me some suggestions (or a new spec file) I'll try to
recompile samba.

Lorenzo

> Can you get a backtrace with nmbd compiled with -g please ? It would be really
> helpful to get the core-dump file and the nmbd binary. I have fedora core 3 on
> x86 and could look at this natively. But without symbols (-g) the backtrace is
> not very useful.
> 
> Jeremy.
Comment 5 Lorenzo Luconi Trombacchi 2005-01-13 09:31:08 UTC
I'm not sure if this is what you want, anyway I have recompiled my samba with -g
options (I hope :-)) ) and this is the backtrace result of gdb:

#0  0x0000002a96359404 in waitpid () from /lib64/tls/libc.so.6
#1  0x0000002a96304832 in do_system () from /lib64/tls/libc.so.6
#2  0x000000552ab3d66b in smb_panic2 () from /usr/sbin/nmbd
#3  0x000000552ab2b8a1 in debug_parse_levels () from /usr/sbin/nmbd
#4  <signal handler called>
#5  0x000000552ab273e4 in ubi_btSgn () from /usr/sbin/nmbd
#6  0x000000552aaeaae8 in initiate_wins_processing () from /usr/sbin/nmbd
#7  0x000000552aad3772 in main () from /usr/sbin/nmbd


Lorenzo


> Can you get a backtrace with nmbd compiled with -g please ? It would be really
> helpful to get the core-dump file and the nmbd binary. I have fedora core 3 on
> x86 and could look at this natively. But without symbols (-g) the backtrace is
> not very useful.
> 
> Jeremy.

Comment 6 Gerald (Jerry) Carter 2005-01-14 08:15:15 UTC
possibly related bug.   

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144865

Is wins proxy set in your smb.conf ?
Comment 7 Gerald (Jerry) Carter 2005-01-14 08:22:13 UTC
another RH bugzilla report (probably duplicate of previous one).
Comment 8 Gerald (Jerry) Carter 2005-01-14 08:49:08 UTC
would have helped if I had posted the actual RH URL....
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=142943
Comment 9 Gerald (Jerry) Carter 2005-02-05 07:57:41 UTC
please retest against 3.0.11 and reopen if necessary.  Also reset 
the version if you reopen the bug report.  Thanks.
Comment 10 Jay Fenlason - please log in and update your mail address here and let us enable Bugmails to you again, Jay 2005-03-09 15:09:26 UTC
Created attachment 1021 [details]
Patch suggested by gcc folks

Since I was never able to reproduce the problem, I haven't tested this.

Come to think of it, I haven't even compiled it.
Comment 11 Gerald (Jerry) Carter 2005-03-09 15:16:30 UTC
i'll take this patch.  The original code is awful :-(
Thanks.
Comment 12 Gerald (Jerry) Carter 2005-08-24 10:19:01 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.