Bug 2206 - [homes] and config file
[homes] and config file
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.9
All Windows XP
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 02:46 UTC by Bryan Chua
Modified: 2005-08-24 10:22 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bryan Chua 2005-01-02 02:46:37 UTC
OK, so maybe what I am doing is very odd.  In the older versions of Samba, I
used to define file smb.conf that was very  minimal:

[global]
 include .../smb.conf.global
 config file .../smb.conf.%U

[public]
 guest ok = yes
 read only = yes
 ...

in the smb.conf.users:
[global]
 include .../smb.conf.global

[homes]
...

[public]
 read only = no

...

In newer versions this still *sort of* works, but the homes share does not show
up from the config file.  I believe that the problem is located in
param/loadparam.c:do_section:

If I define the [homes] share in smb.conf.base then it works correctly.
If I define the [homes] share in smb.conf.users as browsable = yes then it shows
up as "homes"
The code in do_section looks like it will blindly add sections without trapping
the special names HOMES_NAME.  I believe that somewhere there should be a call
to smbd/service.c:find_service(), but I am not sure where it should be.  I
suspect this bug exists for "printers" as well.
Comment 1 Gerald (Jerry) Carter 2005-02-09 06:11:06 UTC
This should be fixed in 3.0.11.  There was an issue with 
variable expansion in include files that I think will 
correct this.  Please test and reopen if necessary,
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:22:47 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.