Bug 2185 - Missing dlopen() when compiling with Heimdal on Solaris
Missing dlopen() when compiling with Heimdal on Solaris
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.10
Sparc Solaris
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 13:14 UTC by Ron Brazeau
Modified: 2013-02-18 13:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Brazeau 2004-12-22 13:14:54 UTC
== Start of configure script ==
#!/bin/sh
LD_LIBRARY_PATH=/usr/local/lib; export LD_LIBRARY_PATH

CC=gcc KRB5_CONFIG=/usr/heimdal/bin/krb5-config
LDFLAGS="-L/usr/local/openldap/lib  -L/usr/heimdal/lib
-R/usr/local/openldap/lib:/usr/heimdal/lib"
CPPFLAGS="-I/usr/local/openldap/include" ./configure --prefix=/usr/local/samba
--with-winbind --with-acl-support --with-krb5=/usr/heimdal --with-ldap
--with-ads --with-libiconv=/usr/local/lib
== END of configure script ==

cd samba-3.0.10/source
../../configure-nrcan

I get fatal errors in config.log (and later, I cannot join the domain as I get
Segmentation Fault errors):

configure:10956: checking for library containing dlopen
configure:10986: gcc -o conftest -O  -I/usr/local/openldap/include -D_LARGEFILE_
SOURCE -D_REENTRANT -D_FILE_OFFSET_BITS=64 -L/usr/local/openldap/lib  -L/usr/hei
mdal/lib -R/usr/local/openldap/lib:/usr/heimdal/lib -lthread conftest.c  >&5
Undefined                       first referenced
 symbol                             in file
dlopen                              /var/tmp//ccsFHe5A.o  (symbol belongs to imp
licit dependency /usr/lib/libdl.so.1)
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:10992: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define HAVE_VOLATILE 1
| #define SYSV 1
| #define _LARGEFILE64_SOURCE 1
| #define _FILE_OFFSET_BITS 64
| #define STDC_HEADERS 1
| #define HAVE_DIRENT_H 1
| #define TIME_WITH_SYS_TIME 1
| #define HAVE_SYS_WAIT_H 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_ARPA_INET_H 1
| #define HAVE_SYS_FCNTL_H 1
| #define HAVE_SYS_SELECT_H 1
| #define HAVE_FCNTL_H 1
| #define HAVE_SYS_TIME_H 1
| #define HAVE_SYS_UNISTD_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_UTIME_H 1
| #define HAVE_GRP_H 1
| #define HAVE_LIMITS_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_RPC_RPC_H 1
| #define HAVE_RPCSVC_NIS_H 1
| #define HAVE_RPCSVC_YP_PROT_H 1
| #define HAVE_RPCSVC_YPCLNT_H 1
| #define HAVE_SYS_PARAM_H 1
| #define HAVE_CTYPE_H 1
| #define HAVE_SYS_WAIT_H 1
| #define HAVE_SYS_RESOURCE_H 1
| #define HAVE_SYS_IOCTL_H 1
| #define HAVE_SYS_IPC_H 1
| #define HAVE_SYS_MODE_H 1
| #define HAVE_SYS_MMAN_H 1
| #define HAVE_SYS_FILIO_H 1
| #define HAVE_SYS_SHM_H 1
| #define HAVE_STRING_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_SYS_SOCKET_H 1
| #define HAVE_SYS_MOUNT_H 1
| #define HAVE_SYS_VFS_H 1
| #define HAVE_TERMIOS_H 1
| #define HAVE_TERMIO_H 1
| #define HAVE_SYS_TERMIO_H 1
| #define HAVE_SYS_STATFS_H 1
| #define HAVE_SYS_STATVFS_H 1
| #define HAVE_STDARG_H 1
| #define HAVE_SYS_SOCKIO_H 1
| #define HAVE_SYS_SYSMACROS_H 1
| #define HAVE_DLFCN_H 1
| #define HAVE_SYS_SYSLOG_H 1
| #define HAVE_SYSLOG_H 1
| #define HAVE_LANGINFO_H 1
| #define HAVE_LOCALE_H 1
| #define HAVE_SHADOW_H 1
| #define HAVE_NETINET_TCP_H 1
| #define HAVE_NETINET_IN_SYSTM_H 1
| #define HAVE_NSS_COMMON_H 1
| #define HAVE_NSSWITCH_H 1
| #define HAVE_SECURITY_PAM_APPL_H 1
| #define HAVE_STROPTS_H 1
| #define HAVE_POLL_H 1
| #define HAVE_SYS_SYSCALL_H 1
| #define HAVE_SYS_ACL_H 1
| #define HAVE_GLOB_H 1
| #define HAVE_SECURITY_PAM_MODULES_H 1
| #define HAVE_NET_IF_H 1
| #define HAVE_NETINET_IP_H 1
| #define HAVE_UTMP_H 1
| #define HAVE_UTMPX_H 1
| #define HAVE_LASTLOG_H 1
| #define SIZEOF_INT 4
| #define SIZEOF_LONG 4
| #define SIZEOF_SHORT 2
| #define WORDS_BIGENDIAN 1
| #define RETSIGTYPE void
| #define HAVE_STRUCT_STAT_ST_RDEV 1
| #define HAVE_ST_RDEV 1
| #define HAVE_DIRENT_D_OFF 1
| #define loff_t off_t
| /* end confdefs.h.  */
|
| /* Override any gcc2 internal prototype to avoid an error.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| /* We use char because int might match the return type of a gcc2
|    builtin and then its argument prototype would still apply.  */
| char dlopen ();
| int
| main ()
| {
| dlopen ();
|   ;
|   return 0;
| }
Comment 1 Ron Brazeau 2004-12-23 07:19:11 UTC
When I did the make install, I got some strange warnings (it seems to have "//"
in some places which may clobber it...

cp: cannot access
/home8/src/samba/samba-3.0.10/source/../docs/htmldocs//images/*.png
Cannot install /usr/local/samba/swat/help//images/*.png. Does have privileges?

/usr/local/samba/swat/help/Samba-Developers-Guide/images/*.png
cp: cannot access
/home8/src/samba/samba-3.0.10/source/../docs/htmldocs/Samba-Developers-Guide/images/*.png
Cannot install /usr/local/samba/swat/help/Samba-Developers-Guide/images/*.png.
Does have privileges?
chmod: WARNING: can't access
/usr/local/samba/swat/help/Samba-Developers-Guide/images/*.png

./install-sh -c bin/libsmbclient.so //usr/local/samba/lib: bin/libsmbclient.a
//usr/local/samba/lib
./install-sh -c /home8/src/samba/samba-3.0.10/source/include/libsmbclient.h
//usr/local/samba/include
Comment 2 Gerald (Jerry) Carter 2005-02-07 10:32:54 UTC
please test 3.0.11 and report back.  Thanks,
Comment 3 Gerald (Jerry) Carter 2005-02-17 10:18:28 UTC
closing awaiting feedback on whwther the bug in fixed in 3.0.11 or not.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:18:01 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.