Bug 2183 - LDAP: Samba does not follows "ldap user suffix" to get user information
LDAP: Samba does not follows "ldap user suffix" to get user information
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.9
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 07:22 UTC by Vinicius Moreira Mello
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinicius Moreira Mello 2004-12-22 07:22:21 UTC
Not a bug, but an inconvenient default.

By default samba searches for the user's base under "ldap suffix". But this
limits  samba objects and users's objects to be under the same subtree. For
example, you cannot use ou=Samba,dc=my-domain,dc=org as "ldap suffix" and have
users "ldap user suffix" under ou=Unix,dc=mydomain,dc=org. It would be more
reasonable if users's and computer's lookups were done under the same suffix
they're added. It's not always that is possible to mix samba and Unix objects,
especially when you have a large directory service.
Comment 1 Gerald (Jerry) Carter 2005-02-07 10:57:33 UTC
fixed in 3.0.11
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:19:16 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.