Bug 2170 - print que not updating
print que not updating
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.9
Sparc Solaris
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 05:30 UTC by Olaf Imig
Modified: 2005-08-24 10:28 UTC (History)
2 users (show)

See Also:


Attachments
Dump of printing/liblev2.dump (2.30 KB, text/plain)
2005-01-12 04:21 UTC, Michael Young
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Imig 2004-12-17 05:30:13 UTC
Hallo,

My System: Samba 3.0.9 with printing-3.0.9-patch as printserver (Domainmember)
on Sparc-Solaris-2.8 with CUPS-Server in a WINDOWS 2003 Server Domain.
The BUG was already described by Spike Burkhardt and answered by Gerald (Jerry)
Carter.(lists.samba.org/archive/samba/2004-October/094707.html). The problem
isn't solved.
Here a short description:  
When I print a file from a Windows-XP-Client over my printserver the job prints,
the file get deleted on the server but in my system tray, it seems like the job
never gets removed from the que. It seems like once the job doesn't get removed
from the que it won't unless I specifically cancel the job. After I restart the
samba server the problem vanish some times.

m.f.g.
Comment 1 Michael Young 2004-12-22 04:03:50 UTC
I am seeing this as well with a slightly modified version of 3.0.10 (see bug
2107), with samba on Solaris 9 and printing=sysv. It seems that jobs are aren't
being removed from the samba print job list after they have been printed and are
no longer on the Solaris print queue. There is also a weirdness if you view the
queue with smbclient from solaris, as the first "queue" command gives the job
number as 1-11 and the second and subsequent lists multiplies these numbers by 256.
Comment 2 Olaf Imig 2004-12-22 06:32:13 UTC
(In reply to comment #1)
> I am seeing this as well with a slightly modified version of 3.0.10 (see bug
> 2107), with samba on Solaris 9 and printing=sysv. It seems that jobs are aren't
> being removed from the samba print job list after they have been printed and are
> no longer on the Solaris print queue. There is also a weirdness if you view the
> queue with smbclient from solaris, as the first "queue" command gives the job
> number as 1-11 and the second and subsequent lists multiplies these numbers by
256.
I see the same behavior, if I view the queue with smbclient.
Comment 3 Gerald (Jerry) Carter 2005-01-05 20:34:10 UTC
please test 3.0.11pre1.  There is a chance this has been fixed (50/50 maybe).
Comment 4 Gerald (Jerry) Carter 2005-01-06 07:21:51 UTC
Got a confirmation that the bug is indeed fixed in 3.0.11pre1.
Comment 5 Olaf Imig 2005-01-06 09:39:18 UTC
(In reply to comment #4)
> Got a confirmation that the bug is indeed fixed in 3.0.11pre1.
At this time it seems that the bug is fixed. But the the problem with the
jobnumbers described by Michael Young in Comment1 (There is also a weirdness if
you view the
queue with smbclient from solaris, as the first "queue" command gives the job
number as 1-11 and the second and subsequent lists multiplies these numbers by
256.) still exist.
Comment 6 Gerald (Jerry) Carter 2005-01-06 09:45:48 UTC
Ithink the odd job id's ia a byte ordering bug and different 
that the other reported issue of jobs not being cleared from 
queues that was reported on multiple platforms.  Reopening the 
bug to deal with SOlaris.
Comment 7 Gerald (Jerry) Carter 2005-01-06 09:46:38 UTC
*** Bug 1998 has been marked as a duplicate of this bug. ***
Comment 8 Michael Young 2005-01-12 04:01:30 UTC
Actually I have had a reoccurence of the original queue problem with 3.0.11pre1.
One extra thing I have noticed; from the windows list of all printers the total
jobs in a queue is larger than the number of jobs listed if you view the queue,
which suggests that sometimes a job is only partially deleted.
Comment 9 Michael Young 2005-01-12 04:21:30 UTC
Created attachment 886 [details]
Dump of printing/liblev2.dump

This is a dump of one of the file which is presumably associated to one of the
print queues liblev2. I notice it contains tags associated to a different queue
cm131col which seems strange to me.
Comment 10 Andrzej Zawadzki 2005-01-13 04:03:21 UTC
(In reply to comment #4)
> Got a confirmation that the bug is indeed fixed in 3.0.11pre1.

:-( Not yet - On linux x86 today I have again 600 print jobs on Windows Printer
view. Samba is builded from this spec:

http://cvs.pld-linux.org/cgi-bin/cvsweb/SPECS/samba.spec
Comment 11 Michael Young 2005-01-14 05:35:51 UTC
I have now tried adding the patch mentioned in
http://lists.samba.org/archive/samba/2005-January/098266.html
and, so far at least, I haven't seen the print queue build up problem occuring.
Comment 12 Andrzej Zawadzki 2005-01-15 02:45:17 UTC
(In reply to comment #11)
> I have now tried adding the patch mentioned in
> http://lists.samba.org/archive/samba/2005-January/098266.html
> and, so far at least, I haven't seen the print queue build up problem occuring.
Yes! Thanks!! Now my Win 98 clients doesn't get stack.
Comment 13 Eduard Bloch 2005-01-15 09:37:39 UTC
The problem on AIX is not fixed with 3.0.11pre1 and this patch. Still insane ID
numbers in smbclient's "queue" output when running it multiple times, and not
beeing able to cancel jobs, not reliable. Windows XP could never delete a job.

I have the impression that it has improved for one situation: if smbd is freshly
restarted you are the only connected client and you use the virtual ID number
that you got from the first "queue" command to run "cancel ID", then it mostly
works.
Comment 14 Daniel Beschorner 2005-01-18 05:27:56 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > I have now tried adding the patch mentioned in
> > http://lists.samba.org/archive/samba/2005-January/098266.html
> > and, so far at least, I haven't seen the print queue build up problem 
occuring.
> Yes! Thanks!! Now my Win 98 clients doesn't get stack.

CVS (or .11pre1+one line patch) is working for us fine too, no jobs stay any 
longer in the queue, W2K/XP.
Comment 15 Gerald (Jerry) Carter 2005-02-03 07:24:19 UTC
looks like we're done here.
Comment 16 Michael Young 2005-05-05 01:55:21 UTC
I have had a minor reoccurance of this with 3.0.14a. Some jobs were left in one
queue in the "spooling" state, from about a week ago. There is no sign the jobs
ever reached the server, so I am guessing they failed for some reason (maybe
cancelled or the application sending them crashed), so the bug may still exist
in a rare case.
Comment 17 Gerald (Jerry) Carter 2005-08-24 10:28:17 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.