Bug 2169 - smbd doesn't copy mangled name with wild char.
smbd doesn't copy mangled name with wild char.
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.0preX
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 05:09 UTC by didier
Modified: 2006-04-08 11:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description didier 2004-12-17 05:09:10 UTC
How to reproduce:
On the server create a file test<.jpg and a directory 'folder' 
mount the volume.
$ ls /mnt/test
TPP3NO~6JPG folder
$ cp /mnt/test/TPP3NO~6.JPG /mnt/test/folder
error.

Possible fix:
Remove the test if (ms_has_wild) in source/smbd/open.c open_file() function.
Comment 1 Gerald (Jerry) Carter 2005-02-07 08:30:33 UTC
is this still an issue in 3.0.11 ?
Comment 2 Gerald (Jerry) Carter 2005-02-10 06:58:18 UTC
reporter says still an issue on 3.0.11.
I don't see any weildcard charater in your 
example.  

This looks like a smbfs issue.  We don't support 
smbfs however.  You'll need to talk to the kernel 
maintainers about that.

You could try the cifs fs support in the linux 2.6.
kernel.http://us2.samba.org/samba/Linux_CIFS_client.html

Also, in the future, it is better to keep comment to bugzilla 
and not reply directly via email (helps to track the issue 
more directly).
Comment 3 didier 2005-02-10 10:40:49 UTC
(In reply to comment #2)
> reporter says still an issue on 3.0.11.
> I don't see any weildcard charater in your 
> example.  
What is "<"?
> 
> This looks like a smbfs issue.  We don't support 
> smbfs however.  You'll need to talk to the kernel 
> maintainers about that.
I don't think so.
Either the test in open.c open_file() 
if ((local_flags & O_CREAT) && !VALID_STAT(*psbuf)  && ms_has_wild(fname))
is wrong
or unix_convert() shouldn't be call when creating a file.
> 
> You could try the cifs fs support in the linux 2.6.
> kernel.http://us2.samba.org/samba/Linux_CIFS_client.html
same, both nttrans and smb fn call unix_convert() before calling open_file_shared...

> 
> Also, in the future, it is better to keep comment to bugzilla 
> and not reply directly via email (helps to track the issue 
> more directly).
Ok
Comment 4 Gerald (Jerry) Carter 2006-04-08 11:49:12 UTC
please reopen if the bug still exists in a current release.