Bug 2135 - Error building lib/replace.c on HPUX 11.00
Error building lib/replace.c on HPUX 11.00
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.7
PA-RISC HP-UX
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 08:57 UTC by Olivier Mehani
Modified: 2005-08-24 10:21 UTC (History)
0 users

See Also:


Attachments
Changing the function declaration to match the header' prototype solves the problem (498 bytes, patch)
2004-12-08 09:02 UTC, Olivier Mehani
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Mehani 2004-12-08 08:57:52 UTC
When building Samba with ADS support (heimdal-0.6.3,openldap-2.2.17), I get this
error:

Compiling lib/replace.c
(...)
lib/replace.c:419: conflicting types for `vsyslog'
include/proto.h:515: previous declaration of `vsyslog'
make: *** [lib/replace.o] Error 1
Comment 1 Olivier Mehani 2004-12-08 09:02:29 UTC
Created attachment 830 [details]
Changing the function declaration to match the header' prototype solves the problem

"void vsyslog (int facility_priority, char *format, va_list arglist)"
becomes
"void vsyslog (int facility_priority, const char *format, va_list arglist)"
to match include/proto.h's declaration
Comment 2 Olivier Mehani 2004-12-13 06:25:21 UTC
BTW, it works for me...
Comment 3 Tim Potter 2004-12-18 17:53:04 UTC
Fixed.  BTW the setting resolved/worksforme is meant to indicate that the bug
was invalid in the first place rather than that the fix you suggested works.
Comment 4 Tim Potter 2004-12-18 17:53:34 UTC
Marking as fixed.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:21:00 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.