Bug 2133 - Error building clikrb5 on HPUX 11.00
Error building clikrb5 on HPUX 11.00
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.7
PA-RISC HP-UX
: P3 regression
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 08:52 UTC by Olivier Mehani
Modified: 2004-12-13 06:24 UTC (History)
0 users

See Also:


Attachments
Including roken.h in the beginning of clikrb5.c fixes the problem (261 bytes, patch)
2004-12-08 08:52 UTC, Olivier Mehani
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Mehani 2004-12-08 08:52:08 UTC
When building Samba with ADS support (heimdal-0.6.3,openldap-2.2.17), I get this
error:

Compiling libsmb/clikrb5.c
(...)
libsmb/clikrb5.c: In function `krb5_locate_kdc':
libsmb/clikrb5.c:225: dereferencing pointer to incomplete type
libsmb/clikrb5.c:226: dereferencing pointer to incomplete type
libsmb/clikrb5.c: In function `krb5_princ_component':
libsmb/clikrb5.c:470: warning: assignment discards qualifiers from pointer
target type
make: *** [libsmb/clikrb5.o] Error 1
Comment 1 Olivier Mehani 2004-12-08 08:52:47 UTC
Created attachment 829 [details]
Including roken.h in the beginning of clikrb5.c fixes the problem
Comment 2 Olivier Mehani 2004-12-13 06:24:24 UTC
BTW, it works for me...