Bug 213 - Bug in "Makefile.in"
Bug in "Makefile.in"
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
All HP-UX
: P2 regression
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-10 11:04 UTC by Ryan Novosielski
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Novosielski 2003-07-10 11:04:33 UTC
I built under the following conditions:

--with-quotas --with-pam --with-pam_smbpass --with-utmp --without-winbind

In this case, EXTRA_SBIN_PROGS in Makefile.in is undefined, meaning that:

SBIN_PROGS = bin/smbd@EXEEXT@ bin/nmbd@EXEEXT@ bin/swat@EXEEXT@ \
        @EXTRA_SBIN_PROGS@

becomes:

SBIN_PROGS = bin/smbd bin/nmbd bin/swat \

...generating "Don't know how to make BIN_PROGS1" errors because BIN_PROGS1 = is
concatenated to the SBIN_PROGS line.
Comment 1 Tim Potter 2003-07-10 20:32:50 UTC
Fixed in CVS.

Incidentally, which version of Make are you using?  The copy of GNU make I have
installed on my development system handles this situation fine.
Comment 2 Ryan Novosielski 2003-07-11 07:29:58 UTC
I am running HP make revision 82.20.1.7 last patched on 5/25/1999. I do have 
GNU make available, but I typically stick to HP unless something requires me to 
do otherwise, because GNU is not installed everywhere.

Thanks for the quick response!
Comment 3 Tim Potter 2003-07-11 16:31:43 UTC
Thanks for the info.  We try and keep Samba compiling with vendor makes for the
reason you describe.
Comment 4 Gerald (Jerry) Carter 2005-02-07 08:40:45 UTC
originally reported against 3.0.0beta2.  CLeaning out 
non-production release versions.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:24:51 UTC
database cleanup