Bug 2122 - Storing DOS attributes in EAs doesn't work for some filenames
Storing DOS attributes in EAs doesn't work for some filenames
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.7
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-04 15:36 UTC by Lars Soltau
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Soltau 2004-12-04 15:36:25 UTC
When a directory name contains a colon ':' and the option "store dos attributes"
is enabled, any read request from an XP client for a file in that directory
fails. The smbd log contains the following line:

get_ea_dos_attributes: Cannot get attribute from EA on file .: Error = Operation
not permitted

The directory resides on an XFS filesystem under Linux, Kernel 2.6.9.
Comment 1 Gerald (Jerry) Carter 2005-02-17 10:29:16 UTC
':' is an invalid character in a Win32 filename?
Are we not mangling the name?   Pleas retest against 3.0.11
and reopen if the issue is still present.  
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:19:15 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.