Bug 2117 - windows XP SP2 - very slow upload speed
windows XP SP2 - very slow upload speed
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
x86 Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 18:06 UTC by markus madlener
Modified: 2005-08-24 10:19 UTC (History)
0 users

See Also:


Attachments
log files with log level 10 when upload a 2MB file (52.33 KB, text/tgz)
2004-12-02 18:10 UTC, markus madlener
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description markus madlener 2004-12-02 18:06:47 UTC
hi

i'm having perfomance problems when uploading files to a samba server
test file size:
upload speed:   <300kB/s !
download speed: >20MB/s
client:  Windows XP Service Pack 2
server:  Linux Debian Sarge testing 20041027,  kernel 2.4.27-1-386,
         using latest debian samba package 3.0.8-2  
network: gigabit ethernet

recent reports related to this problem 
(the reason why i filled out the bug report): 
krister
http://lists.samba.org/archive/samba/2004-November/095191.html
dave
http://lists.samba.org/archive/samba/2004-October/094567.html
graeme walker
http://lists.samba.org/archive/samba/2004-November/095613.html

..and a few others reported performance issues when printing
printing = uploading files to the samba server
i have not found any solution in the list archives so far

tests i made:
- samba: log level=0
- samba: socket options TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
SO_KEEPALIVE
- samba: different locking options
- tested diffent samba versions in addition to the debian samba package:
  self-compiled: 2.2.12 3.0.5 and 3.0.9  (using all default options except  
  different --prefix options)

- winXP SP2 machine: smb upload <300kB/s ! and download >20MB/s to the 
  samba server
- winXP SP2 machine: ftp upload and download to the ftp and samba server 
  is OK both >20MB/s
- winXP SP2 machine: webclient service disabled
- winXP SP2 machine: firewall disabled, no other network limiting sw installed
- win2000 SP4 machine: smb upload and download to the samba server is OK 
  both > 20MB/s

one of the smb.conf's i tested (very simple) :
[global]
   workgroup = OPENCL
   server string = Samba Server
   security = user

   log level = 0
   load printers = no
   log file = /usr/local/opt/samba/3.0.9/var/log.%m
   dns proxy = no

[homes]
   comment = Home Directories
   browseable = no
   writable = yes

attached the log with log level = 10 when trying to upload a 2MB x.wmv file,
takes about 7sec

please respond if i should make a log file when using the windows 2000
workstation to upload a file

reading the other reports i guess that the problem is SP2 related, maybe SP2 has
some network limitations regarding the smb protocol in relation to samba ?

is there anything else i can test ?
best regards
markus madlener
Comment 1 markus madlener 2004-12-02 18:10:00 UTC
Created attachment 822 [details]
log files with log level 10 when upload a 2MB file

log.smbd     is the samb server Athlon XP 1500+  SW RAID 5 600GB
log.lorbeer  is the windows XP SP2 machine Athlon XP 2600+ 160GB disk
Comment 2 Jeff Sidlosky 2005-01-29 02:02:59 UTC
I am having a similar problem but have some more information. 

My problems are transfering a file from samba to XP (sounds like reverse of your
problem?)... 

If I leave send/recv buffers to default in v3.0.10 of samba, then I get like
<10mbit/s when downloading a file.  If I start a subsequent download, the total
rate goes to 400mb/s!, until one of them finishes then the other goes to
10mbit/s again.  If I dl the same file twice to the same location, Windows XP
prompts you "are you sure you wish to overwrite this file?", durring the time
that the dialog box is up, the first download goes to 400mb/s, even though a
second transfer isn't running, but is "pending to run", e.g. a second connection
to the samba server is open.  

If I set the send/recv buffers in smb.conf to 8192/8192, my transfer rates go to
~200mbit/s but not very stable or smooth... 

If I set: oplocks = no  (in [general]), then my download rates are always
400mb/s! even with one download going instead of two.  At this point leave
send/recv buffers to default, or set to 16384 or 32768 and I get 400mb/s... 

So, the final work arround for the Windows XP SP2 (Service Pack 2), is to set
oplocks = no. 

Now I am having a new problem though, can't open video files through media
player over the samba drive... I am going to reboot my XP machine to see if it
resolves it. 
Comment 3 Gerald (Jerry) Carter 2005-02-17 09:19:18 UTC
please retest against 3.0.11.  If you find the issues , still exists, 
we'll probably need raw ethereal/tcpdump network traces of good 
and bad sessions to figure out what's going on.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:19:29 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.