Bug 2079 - No printing share after upgrade to Samba 3.0.9
No printing share after upgrade to Samba 3.0.9
Status: RESOLVED DUPLICATE of bug 2091
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.9
x86 Windows 2000
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 05:56 UTC by Vladislav Krahulec
Modified: 2004-12-02 10:23 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav Krahulec 2004-11-23 05:56:10 UTC
Server with Samba: HP TC4100 (Intel PIII/1400, 2GB RAM) SuSE Linux 9.0
machine on net: Intel P4/1600, Windows 2000 SP4 and all last hotfixes

After upgrade from 3.0.7 to 3.0.9 my network printers are completly not 
accessible. I used almost the same smb.conf in several 2.2.x versions, then
I have upgraded to 3.0.7 and after some minor changes everything was good.

But after upgrade to 3.0.9 file shares are O.K. but I cannot access any print 
share on my Windows 2000 SP4 machine.

I have used RPM's from ftp://ftp.suse.com/pub/projects/samba/3.0/i386/9.0/, 
because of SuSE Linux 9.0 on my server.

I also have already tried RPM for SuSE Linux 9.1
(on another machine with 9.1 distribution, which I have for test purposes)
- ftp://ftp.suse.com/pub/projects/samba/3.0/i386/9.1/ -
and I have got the same result - with older 3.0.7 I can see print shares and
after upgrade to 3.0.9 I can see only file shares even with default smb.conf .

Because I still have not any packages with Samba 3.0.7 for SuSE Linux 9.0 I had
to return to 2.2.8a version which is native in SuSE 9.0 distribution.

I have no idea about reason for this, if it is mistake of compiling in SuSE or
bug in Samba 3.0.9 but I would like to use Samba3 with print shares.

(Sorry for my czenglish ...)

Vladislav Krahulec
Prague
Comment 1 Vladislav Krahulec 2004-11-23 08:44:24 UTC
What is wrong with this configuration ???

smb.conf 

# Global parameters
[global]
	workgroup = XXXXX
	security = SHARE
	load printers = No
	printcap name = /etc/printcap
	preferred master = No
	local master = No
	domain master = No
	ldap ssl = no
	printer admin = @ntadmin, root, administrator
	printing = lprng
	print command = lpr -r -P'%p' %s
	lpq command = lpq -P'%p'
	lprm command = lprm -P'%p' %j
	lppause command = lpc hold '%p' %j
	lpresume command = lpc release '%p' %j
	queuepause command = lpc stop '%p'
	queueresume command = lpc start '%p'
	include = /etc/samba/dhcp.conf

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin, root
	force group = ntadmin
	create mask = 0664
	directory mask = 0775

[bety]
	comment = bety - magicolor 2300dl
	path = /tmp
	guest ok = Yes
	printable = Yes
	printer name = bety

Comment 2 Gerald (Jerry) Carter 2004-12-02 10:23:32 UTC
I'm pretty sure this is a duplicate of bug 2091 which has been fixed for the
upcoming 3.0.10pre1 release.

*** This bug has been marked as a duplicate of 2091 ***