Bug 2053 - Mp3 playback jumping
Mp3 playback jumping
Status: VERIFIED FIXED
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x86 Linux
: P3 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 18:06 UTC by Marius Flage
Modified: 2006-11-02 11:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Flage 2004-11-17 18:06:08 UTC
Problems with a smb mounted filesystem, mounted from a windows machine. Share
used to play mp3s, and to play them constantly - once a file's done playing a
new one is played. Worked fine on a box running debian woody (stable) on 2.4.
But, after changing to a different box running Debian Sarge and 2.6 playback
would skip now and then. And it seems pretty perodical, like every 10 or 20
minutes, so it could nearly be timed, just a few seconds off every time. So, it
didn't seem random, but more like a timer or buffer or something creating the
skips. Tried both smbfs and cifs under 2.6 - none worked.
Comment 1 Steve French 2005-03-07 21:13:15 UTC
Could you add your kernel version - if version 2.6.10 or later I would be 
surprised at problems in mp3 playback as you describe and would like more 
details.  In particular if 2.6.10 or later kernel (or cifs version 1.28 or 
later) I would like to see contents of /proc/fs/cifs/DebugData after it skipped 
to see if the smb session crashed and any thing cifs related dumped to dmesg 
Comment 2 Marius Flage 2005-03-18 06:01:54 UTC
I'm now using 2.4.28, but the problem is not so big as when I ran 2.6.x, but
it's still there. I'm now using smbfs.
Comment 3 Steve French 2005-04-14 09:33:48 UTC
I want to confirm that this works fine on current 2.6.  Which tool do use you to
play mp3s (they likely use different buffering).
Comment 4 Marius Flage 2005-04-14 10:41:22 UTC
mpg321

I've also tried mpg123, but the same thing happens there.
Comment 5 Steve French 2006-11-02 11:29:27 UTC
I would not expect problems for this type of application beyond 2.6.12 or so.

If old smbfs performs better to your server for this i/o pattern, setting rsize on the mount (rsize=4096) would mimic the i/o pattern that older smbfs uses.
Comment 6 Steve French 2006-11-02 11:31:10 UTC
Please reopen if you see similar problems on cifs versions later than cifs version 1.41 (backport to older kernels of cifs 1.45 is available on the download site).
Comment 7 Steve French 2006-11-02 11:31:20 UTC
Please reopen if you see similar problems on cifs versions later than cifs version 1.41 (backport to older kernels of cifs 1.45 is available on the download site).