Bug 2039 - error during compilation of dynconfig.c
error during compilation of dynconfig.c
Status: RESOLVED DUPLICATE of bug 2006
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.8
Sparc Solaris
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 09:20 UTC by Konrad Mauz
Modified: 2004-11-15 14:07 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konrad Mauz 2004-11-15 09:20:17 UTC
I tried to build samba 3.0.8 on Solaris 9.
The configure script runs well with these parameters:
./configure --with-acl-support --with-winbind \
--with-python=/usr/local/bin/python --with-quotas \
--with-ads --with-dce-dfs --with-utmp --prefix=/usr/local/samba3\
--with-included-popt


During the compilation make ( or gcc ) stops with:

--- schnipp ---
Compiling dynconfig.c
In file included from include/includes.h:792,
                 from dynconfig.c:21:
tdb/tdb.h:114: argument format specified for non-function `log_fn'
make: *** [dynconfig.o] Error 1
--- schnapp ---

Version 3.0.5, 3.0.6 and 3.0.7 builds and runs ok in this environment, with
the same configure options.

I have googled and have found one mailinglist thread with the same problem but
no solution.

With kind regards,
Konrad Mauz

PS: the samba team does a very good job.
Comment 1 Jeremy Allison 2004-11-15 14:01:58 UTC
Looks like a gcc bug to me.
log_fn is definately a function pointer...
Jeremy.
Comment 2 Gerald (Jerry) Carter 2004-11-15 14:07:32 UTC

*** This bug has been marked as a duplicate of 2006 ***