Bug 2026 - "net ads leave" causes segmentation fault
"net ads leave" causes segmentation fault
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: net utility
3.0.8
x86 Linux
: P3 minor
: none
Assigned To: Jim McDonough
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 16:52 UTC by Erik Sørnes
Modified: 2005-08-24 10:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Sørnes 2004-11-11 16:52:35 UTC
After successfully joining suse linux professional 9.1 or sles 9.0 to ad2003
domain(singel domain, singel forrest, 10 users in domain or 3 domains, signle
forest > 2000 users in domain) "net ads leave" results in "segmentation fault",
leaving the computer account still in the domain.
However  "net ads leave -d 3" causes the command to complete successfully,
removing the computer account from the domain!

heimdal-0.6.1rc3-51
Linux server 2.6.4-52-default

krb5.conf:[libdefaults]
        default_realm = HJEMME.HOME 
        clockskew = 300

[realms]
        HJEMME.HOME = {
                kdc = hjemme.home
                admin_server = hjemme.home
                kpasswd_server = hjemme.home 
        }
        OTHER.REALM = {
                kdc = OTHER.COMPUTER
        }

[domain_realm]
        .HJEMME.HOME = HJEMME.HOME 

[logging]
        default = SYSLOG:NOTICE:DAEMON
        kdc = FILE:/var/log/kdc.log
        kadmind = FILE:/var/log/kadmind.log

[appdefaults]
        pam = {
                ticket_lifetime = 1d
                renew_lifetime = 1d
                forwardable = true
                proxiable = false
                retain_after_close = false
                minimum_uid = 0
                debug = false
        }

smb.conf:[global]
        security=ADS
        realm=HJEMME.HOME
        encrypt passwords=yes
        password server=hjemme.home
        winbind cache time = 3
        winbind separator = +
        workgroup = NETBIOS 
        auth methods = winbind
        #obey pam restrictions = yes
        #winbind use default domain = yes
        interfaces = 127.0.0.1 eth0 eth1
        #bind interfaces only = true
        printing = cups
        idmap uid = 10000-40000
        idmap gid = 10000-40000
        printcap name = cups 
        printer admin = @ntadmin, root, administrator
        map to guest = Bad User
[groups]
        comment = All groups
        path = /home/groups
        writeable = Yes
        inherit permissions = Yes
Comment 1 Guenther Deschner 2004-11-11 17:05:11 UTC
Thanks for the report.

This is caused by a Heimdal-bug, not by a Samba-bug. 
Same cause and solution as #2025.
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:24:33 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.