Bug 1996 - Bugs in postgresql backend...
Bugs in postgresql backend...
Status: RESOLVED DUPLICATE of bug 2334
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.7
x86 All
: P3 normal
: none
Assigned To: Jelmer Vernooij
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 10:36 UTC by Nick Altmann
Modified: 2005-03-10 15:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Altmann 2004-11-04 10:36:39 UTC
Hello!

There is some bugs in postgresql code... 2 of them I resolved (see patch below),
1 - I cannot. Please, help!

1. Columns numbers didn't correspond with names... (resolved, patch1)
2. I cannot add computer into domain because name case from workstation doesn't
agree with database. (resolved, patch2)
3. I can add domain group into local group in WinXP, but I cannot add domain
user to XP local group.
   It was an error: "Information returned from the objeck picker for object
"user" was incomplete. The object will not be processed".
   I watched log level 10 logs and found there nothing.

Please, HELP!!!

Nick.


diff -durN samba-3.0.7.orig/source/passdb/pdb_pgsql.c
samba-3.0.7/source/passdb/pdb_pgsql.c
--- samba-3.0.7.orig/source/passdb/pdb_pgsql.c  2004-04-04 11:37:36.000000000 +0400
+++ samba-3.0.7/source/passdb/pdb_pgsql.c       2004-11-03 14:17:33.000000000 +0300
@@ -98,9 +98,10 @@
  pdb_set_munged_dial          ( u, PQgetvalue( r, row, 17 ), PDB_SET ) ;

  pdb_set_acct_ctrl            ( u, PQgetlong ( r, row, 23 ), PDB_SET ) ;
-  pdb_set_logon_divs           ( u, PQgetlong ( r, row, 25 ), PDB_SET ) ;
-  pdb_set_hours_len            ( u, PQgetlong ( r, row, 26 ), PDB_SET ) ;
-  pdb_set_logon_count            ( u, PQgetlong ( r, row, 27 ), PDB_SET ) ;
+  pdb_set_logon_divs           ( u, PQgetlong ( r, row, 24 ), PDB_SET ) ;
+  pdb_set_hours_len            ( u, PQgetlong ( r, row, 25 ), PDB_SET ) ;
+  pdb_set_bad_password_count   ( u, PQgetlong ( r, row, 26 ), PDB_SET ) ;
+  pdb_set_logon_count          ( u, PQgetlong ( r, row, 27 ), PDB_SET ) ;
  pdb_set_unknown_6            ( u, PQgetlong ( r, row, 28 ), PDB_SET ) ;

  if ( !PQgetisnull( r, row, 18 ) ) string_to_sid( &sid, PQgetvalue( r, row, 18
) ) ;
diff -durN samba-3.0.7.orig/source/passdb/pdb_sql.c
samba-3.0.7/source/passdb/pdb_sql.c
--- samba-3.0.7.orig/source/passdb/pdb_sql.c    2004-04-04 11:37:36.000000000 +0400
+++ samba-3.0.7/source/passdb/pdb_sql.c 2004-11-03 14:21:48.466735256 +0300
@@ -204,7 +204,7 @@
       }

       asprintf(&query,
-                        "SELECT
%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s
FROM %s WHERE %s = '%s'",
+                        "SELECT
%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s,%s
FROM %s WHERE lower(%s) = lower('%s')",
                        config_value_read(data, "logon time column",
                                                         
CONFIG_LOGON_TIME_DEFAULT),
                        config_value_read(data, "logoff time column",
Comment 1 Jelmer Vernooij 2004-11-25 18:56:50 UTC
Partially applied patch. The lower() stuff hasn't been applied because it breaks
pdb_mysql.
Comment 2 Jelmer Vernooij 2005-01-17 07:32:26 UTC
Downgrading to normal severity since the PostGreSQL backend is still experimental.
Comment 3 Jelmer Vernooij 2005-03-10 15:52:32 UTC
The remainder of this bug report is the same as #2334

*** This bug has been marked as a duplicate of 2334 ***