Bug 1984 - "short utf8 char" errors logged when samba lib/iconv.c is used
"short utf8 char" errors logged when samba lib/iconv.c is used
Status: RESOLVED DUPLICATE of bug 1399
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
All Linux
: P3 normal
: none
Assigned To: Alexander Bokovoy
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-11-01 23:22 UTC by arruah
Modified: 2005-07-21 02:09 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description arruah 2004-11-01 23:22:25 UTC
When Samba is configured to use its own internal iconv functions,
the var/log.$mashine file contains error messages like:

[2004/11/02 12:26:42, 0] lib/iconv.c:utf8_pull(518)
  short utf8 char

when a filename with extended character is processed.
        Dos charset                     = 866
        Unix charset                    = UTF8
        Display charset                 = UTF8
Comment 1 Alexander Bokovoy 2005-01-18 05:32:30 UTC
Could you provide more logging supporting your report?
Comment 2 Björn Jacke 2005-07-21 02:09:42 UTC

*** This bug has been marked as a duplicate of 1399 ***