Bug 1975 - Cannot connect using smbclient
Cannot connect using smbclient
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.7
x86 Linux
: P3 regression
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 15:33 UTC by Anoop Pudhukode
Modified: 2005-08-24 10:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anoop Pudhukode 2004-10-26 15:33:28 UTC
I have problems connecting to samba server from my client machine, both machines
run linux and in the server I have Version 3.0.0-14.3E and in the client machine
I have Version 3.0.7-1.3E

From my client I am trying to use smbclient to get to the home directory of user
qatest and this is what I get.
[root@anoop-laptop2 anoop]# smbclient \\\\192.168.20.151\\qatest -U qatest
Password:
session setup failed: NT_STATUS_LOGON_FAILURE

But I keep checking the /var/log/messages and see these messages going on and on,
Oct 26 15:28:18 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:28:23 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:28:24 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:24, 0]
nmbd/nmbd_serverlistdb.c:write_browse_list(352)
Oct 26 15:28:24 anoop-laptop2 nmbd[1325]:   write_browse_list: Fatal error -
cannot find my workgroup SANA
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:26, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 172 len=4 (Invalid
argument)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:26, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 172 len=4 (Invalid
argument)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:26, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 168 len=4 (Invalid
argument)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:26, 0]
nmbd/nmbd_serverlistdb.c:write_browse_list(352)
Oct 26 15:28:26 anoop-laptop2 nmbd[1325]:   write_browse_list: Fatal error -
cannot find my workgroup SANA
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:27, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 188 len=4 (Invalid
argument)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:27, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 188 len=4 (Invalid
argument)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:27, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 168 len=4 (Invalid
argument)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:27, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:27 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 172 len=4 (Invalid
argument)
Oct 26 15:28:28 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:28:38 anoop-laptop2 last message repeated 2 times
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:41, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 188 len=4 (Invalid
argument)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:41, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 188 len=4 (Invalid
argument)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:41, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 168 len=4 (Invalid
argument)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:41, 0]
nmbd/nmbd_serverlistdb.c:write_browse_list(352)
Oct 26 15:28:41 anoop-laptop2 nmbd[1325]:   write_browse_list: Fatal error -
cannot find my workgroup SANA
Oct 26 15:28:43 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:28:48 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:28:51 anoop-laptop2 nmbd[1325]: [2004/10/26 15:28:51, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:28:51 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 172 len=4 (Invalid
argument)
Oct 26 15:28:53 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:28:58 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:01, 0]
nmbd/nmbd_serverlistdb.c:write_browse_list(352)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]:   write_browse_list: Fatal error -
cannot find my workgroup SANA
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:01, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 352 len=4 (Invalid
argument)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:01, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 352 len=4 (Invalid
argument)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:01, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 168 len=4 (Invalid
argument)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:01, 0]
nmbd/nmbd_serverlistdb.c:write_browse_list(352)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]:   write_browse_list: Fatal error -
cannot find my workgroup SANA
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:01, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:01 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 172 len=4 (Invalid
argument)
Oct 26 15:29:02 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:02, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:02 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 368 len=4 (Invalid
argument)
Oct 26 15:29:02 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:02, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:02 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 368 len=4 (Invalid
argument)
Oct 26 15:29:02 anoop-laptop2 nmbd[1325]: [2004/10/26 15:29:02, 0]
tdb/tdbutil.c:tdb_log(725)
Oct 26 15:29:02 anoop-laptop2 nmbd[1325]:  
tdb(/var/cache/samba/unexpected.tdb): tdb_read failed at 168 len=4 (Invalid
argument)
Oct 26 15:29:03 anoop-laptop2 pam_timestamp_check: pam_timestamp: `/var/'
permissions are lax

Can you tell me what the problem is, this is pretty urgent with regards to our
product development.
Comment 1 Gerald (Jerry) Carter 2004-11-11 13:58:36 UTC
You need to look at a level 10 debug log on the server 
to find out out what the failure is.  I don't see a source 
level bug here.  There's not enough information.

And I'm now sure by what you mean when you state 

     "this is pretty urgent with regards to our product 
      development."
Comment 2 Anoop Pudhukode 2004-11-19 17:58:43 UTC
Today I was ablt to figure out at which point the problem is getting created. In
one of my modules I replace all system calls and it is when I replace pwrite
system call that I get the proble. In var log messages I see the following.
Nov 19 16:25:35 localhost su(pam_unix)[10115]: session opened for user root by
anoop(uid=500)
Nov 19 16:26:47 localhost kernel: In pwrite: retVal=-22
Nov 19 16:26:47 localhost smbd[10188]: [2004/11/19 16:26:47, 0]
tdb/tdbutil.c:tdb_log(724)
Nov 19 16:26:47 localhost smbd[10188]:   tdb(/var/cache/samba/sessionid.tdb):
expand_file write of 1024 failed (Invalid argument)
Nov 19 16:26:55 localhost kernel: In pwrite: retVal=-22
Nov 19 16:26:55 localhost smbd[10189]: [2004/11/19 16:26:55, 0]
tdb/tdbutil.c:tdb_log(724)
Nov 19 16:26:55 localhost smbd[10189]:   tdb(/var/cache/samba/sessionid.tdb):
expand_file write of 1024 failed (Invalid argument)
Nov 19 16:26:58 localhost kernel: In pwrite: retVal=-22
Nov 19 16:26:58 localhost smbd[10193]: [2004/11/19 16:26:58, 0]
tdb/tdbutil.c:tdb_log(724)
Nov 19 16:26:58 localhost smbd[10193]:   tdb(/var/cache/samba/sessionid.tdb):
expand_file write of 1024 failed (Invalid argument)

Please not the return value from pwrite is -22. This problem does not happen
when I dont replace the system call. When I replace the call I just pass the
parameters again to the original syscall handler and it should call the original
one.
Comment 3 Anoop Pudhukode 2004-12-17 14:57:00 UTC
Problem was something else. I fixed my module. There was nothing wrong with Samaba.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:15:37 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.