Bug 1966 - Domain Admin rights on windows clients.
Domain Admin rights on windows clients.
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.0preX
x86 Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 00:47 UTC by bremchandar
Modified: 2005-02-07 07:56 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bremchandar 2004-10-25 00:47:06 UTC
Configured samba PDC with Ldap as the backend.Able to add new computers using 
the smbldap-useradd scripts without any issues.Users are able to login from 
the windows clients into the samba domain.The issue is eventhough the 
group "'Domain'\Domain Admins" account is listed as the Domain administratos 
on the windows client,when i login using the Domain Administrator,and try to 
change the time,im getting an error "You dont have the proper privilege to 
change the system time".But if i add the Domain administrator directly as a 
privliged user,im not getting this error.
Something wrong with the Domain Admin Group settings??Will give you the config 
logs if required.
Thanks in Advance.
Comment 1 bremchandar 2004-10-25 02:35:47 UTC
Btw,
I tested the same with Wondows 2000 servers.It seems to be working 
fine.Problem is appearing only at the XP clients.

Thanks.

(In reply to comment #0)
> Configured samba PDC with Ldap as the backend.Able to add new computers 
using 
> the smbldap-useradd scripts without any issues.Users are able to login from 
> the windows clients into the samba domain.The issue is eventhough the 
> group "'Domain'\Domain Admins" account is listed as the Domain administratos 
> on the windows client,when i login using the Domain Administrator,and try to 
> change the time,im getting an error "You dont have the proper privilege to 
> change the system time".But if i add the Domain administrator directly as a 
> privliged user,im not getting this error.
> Something wrong with the Domain Admin Group settings??Will give you the 
config 
> logs if required.
> Thanks in Advance.

Comment 2 Guenther Deschner 2004-11-16 14:01:31 UTC
is that really 3.0alpha24 where you see these problems?
Comment 3 bremchandar 2004-11-16 20:49:06 UTC
Upgraded samba to the latest version - 3.0.8-0, still the problem persists.No 
clue whats going so weirrrrrd.

Thanks, 
Brem.
Comment 4 Gerald (Jerry) Carter 2005-02-03 17:00:23 UTC
domain admins has to have the <DOMAIN SID>-512 SID assigned to it.
The rid is what matters not the name.  Just guessing based on 
past experiences.  Feel free to reopen if the you think this is a Samba, and not
a Windows, issue.
Comment 5 Gerald (Jerry) Carter 2005-02-07 07:56:55 UTC
originally reported against 3.0aph24.  Bugzilla spring cleaning.  
Removing old alpha versions.