Bug 1942 - Debian - Windows-2000. File transfer not working, while directory tree browsing fine.
Debian - Windows-2000. File transfer not working, while directory tree browsi...
Status: RESOLVED DUPLICATE of bug 1643
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Windows 2000
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-10-15 15:34 UTC by Marcus
Modified: 2004-10-16 15:59 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Marcus 2004-10-15 15:34:14 UTC
Sorry to bother you, but I just came across this annoying problem. I've just
upgraded samba on Debian and the result is that whenever I try to access a file
using explorer on my Windows-2000 box it freezes. I can browse the directory
tree without problem, but if I try to select a file it freezes. 

I've noticed the following errors on my Debian box:


[2004/10/15 23:00:11, 0] lib/util_sock.c:read_socket_data(384)
  read_socket_data: recv failure for 4. Error = Connection reset by peer
[2004/10/15 23:00:11, 1] smbd/service.c:close_cnum(837)
  arthur ( closed connection to service monica

my configuration file is as follows:

# Samba config file created using SWAT
# from (
# Date: 2004/10/15 23:23:07

# Global parameters
	workgroup = AT_HOME
	server string = %h server (Samba %v)
	obey pam restrictions = Yes
	passdb backend = tdbsam, guest
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:*
%n\n .
	syslog = 0
	log file = /var/log/samba/log.%m
	max log size = 1000
	dns proxy = No
	ldap ssl = no
	panic action = /usr/share/samba/panic-action %d
	invalid users = root

	comment = Home Directories
	path = /home/%u
	read only = No
	create mask = 0755
	browseable = No

	comment = All Printers
	path = /tmp
	create mask = 0700
	printable = Yes
	browseable = No
Comment 1 Volker Lendecke 2004-10-16 02:22:18 UTC
Try 'use sendfile = no'

Comment 2 Björn Jacke 2004-10-16 15:55:18 UTC
he already got the answer on the mailing list, so closing this bug

*** This bug has been marked as a duplicate of 1643 ***
Comment 3 Björn Jacke 2004-10-16 15:59:44 UTC
oh, sorry, was not the same one on the mailing list but looked quite similar. If
use sendfile=no does not help, please reopen :)