Bug 1936 - lseek failed in map_ptr
lseek failed in map_ptr
Product: rsync
Classification: Unclassified
Component: core
x86 Windows XP
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2004-10-14 17:03 UTC by Jit Bose
Modified: 2005-04-01 11:22 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jit Bose 2004-10-14 17:03:43 UTC
I just installed rsync version 2.6.3 using CYGWIN under Windows XP on my DELL
laptop. I attempted the following command:

rsync -avuzp -e ssh machine-name:~/work work

machine-name is my work machine running linux. The error I get is:

lseek failed in map_ptr
rsync error: error in file IO (code 11) at fileio.c(228)
rsync error: received SIGUSER! or SIGINT (code 20) at main.c(880)

This exact command works fine when use it to synchronize my home PC with my work
machine. On my home PC, I run linux and have rsync version 2.6.2 installed. So
then I installed rsync version 2.6.2 on my laptop and got the exact same error
as above.
Comment 1 Wayne Davison 2005-02-27 14:14:05 UTC
I've never been able to reproduce this bug.  Are you using the official 2.6.3
cygwin version, or one you compiled yourself?  I've checked in an improved error
message for when the lseek fails, so if you're still seeing this bug, give
2.6.4pre2 a try (coming soon) and see if it will give us a better idea of what
is going wrong.
Comment 2 Wayne Davison 2005-03-18 19:41:25 UTC
No word that this is still a problem, so closing.