Bug 1928 - winbindd INTERNAL ERROR: Signal 11 in pid 7070 (3.0.7-1.1-SUSE)
winbindd INTERNAL ERROR: Signal 11 in pid 7070 (3.0.7-1.1-SUSE)
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.7
x86 Linux
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 20:59 UTC by Mustafa Mehmed
Modified: 2004-10-28 07:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mustafa Mehmed 2004-10-13 20:59:52 UTC
winbindd crashes at startup. Suse Linux 9.1 kernel version 2.6.5-7.108-smp. 
(dual xeon intel board) Samba version 3.0.7-1.1.(installed as rpm from suse.com 
compile) 

Debug level 3 logfile follows: (winbindd.log)
......
[2004/10/14 13:31:28, 3] libads/sasl.c:ads_sasl_spnego_bind(204)
  ads_sasl_spnego_bind: got OID=1 2 840 113554 1 2 2
[2004/10/14 13:31:28, 3] libads/sasl.c:ads_sasl_spnego_bind(204)
  ads_sasl_spnego_bind: got OID=1 2 840 113554 1 2 2 3
[2004/10/14 13:31:28, 3] libads/sasl.c:ads_sasl_spnego_bind(204)
  ads_sasl_spnego_bind: got OID=1 3 6 1 4 1 311 2 2 10
[2004/10/14 13:31:28, 3] libads/sasl.c:ads_sasl_spnego_bind(211)
  ads_sasl_spnego_bind: got server principal name =qutadkg01$@QUT.EDU.AU
[2004/10/14 13:31:28, 1] libsmb/clikrb5.c:ads_krb5_mk_req(313)
  krb5_cc_get_principal failed (No such file or directory)
[2004/10/14 13:31:28, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/10/14 13:31:28, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 10982 (3.0.7-1.1-SUSE)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/10/14 13:31:28, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/10/14 13:31:28, 0] lib/util.c:smb_panic2(1381)
  PANIC: internal error
[2004/10/14 13:31:28, 0] lib/util.c:smb_panic2(1389)
  BACKTRACE: 19 stack frames:
   #0 /usr/sbin/winbindd(smb_panic2+0x1ec) [0x80d2a05]
   #1 /usr/sbin/winbindd(smb_panic+0x25) [0x80d2813]
   #2 /usr/sbin/winbindd [0x80be377]
   #3 /usr/sbin/winbindd [0x80be3ed]
   #4 [0xffffe420]
   #5 /usr/lib/libkrb5.so.17 [0x400b7d12]
   #6 /usr/lib/libkrb5.so.17(krb5_cc_default+0x40) [0x400b7ed0]
   #7 /usr/sbin/winbindd(kerberos_kinit_password+0x85) [0x81920f0]
   #8 /usr/sbin/winbindd(ads_kinit_password+0x76) [0x81922cd]
   #9 /usr/sbin/winbindd [0x818979e]
   #10 /usr/sbin/winbindd(ads_sasl_bind+0x14f) [0x8189ef9]
   #11 /usr/sbin/winbindd(ads_connect+0x285) [0x8183226]
   #12 /usr/sbin/winbindd [0x8085627]
   #13 /usr/sbin/winbindd [0x8088227]
   #14 /usr/sbin/winbindd [0x807ba88]
   #15 /usr/sbin/winbindd(init_domain_list+0xb0) [0x8076691]
   #16 /usr/sbin/winbindd(main+0x5d4) [0x80705e0]
   #17 /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x4025e4b0]
   #18 /usr/sbin/winbindd [0x806e9f1]

smb.conf follows:
[global]
        netbios name = NANTES
        workgroup = QUTAD
        realm = QUT.EDU.AU
        security = ADS
        password server = *
        winbind separator = +
        idmap uid = 10000-200000
        idmap gid = 10000-200000
        winbind enum users = yes
        winbind enum groups = yes
        winbind use default domain = yes
        template homedir = /home/%U
        template shell = /bin/bash
        interfaces = 127.0.0.1 eth0
        bind interfaces only = true
        printing = cups
        printcap name = cups
        load printers = yes
        unix charset = LOCALE
        hide unreadable = yes
        lm announce = no
        log file = /var/log/samba/%m.log
        log level = 1
        logon drive = h:
        logon home = \\nantes\%U
        lanman auth = no
        min protocol = NT1
        time server = yes
        load printers = yes
        admin users = root, mehmed, QUTAD+sci-sms-cso
        valid users = QUTAD+sci-sms-allusers
        hosts allow = 131.181.38.

[homes]
        browsable = no
        read only = no
        force create mode = 0700
        force directory mode = 0700

[printers]
        printable = yes
        guest ok = no
        path = /var/spool/samba
        use client driver = yes
        printer admin = root, mehmed, QUTAD+sci-sms-cso
[print$]
        path = /etc/samba/printdrivers
        browsable = no
        guest ok = no
        write list = root, mehmed, QUTAD+sci-sms-cso

[users]
        browsable = yes
        read only = no
        force create mode = 755
        force directory mode = 755
        guest ok = no
        path = /home
[www]
        browsable = yes
        read only = no
        path = /tmp
[tmp]
        comment = temporary files
        path = /tmp
        read only = yes
Comment 1 Gerald (Jerry) Carter 2004-10-15 06:52:33 UTC
this is a bug in the version of heimdal that ships with SuSE 9.1.
You need to get an updated heimdal lib package from them.
Comment 2 Björn Jacke 2004-10-15 08:42:08 UTC
on ftp.sernet.de you can find RPMs for SUSE which don't have the bug Jerry
mentioned.
Comment 3 Mustafa Mehmed 2004-10-26 16:21:38 UTC
(In reply to comment #2) 
> on ftp.sernet.de you can find RPMs for SUSE which don't have the bug Jerry 
> mentioned. 
The Sernet compiles worked ok. No crashes, however I still have this error in 
winbindd.log : 
 
:::::::::::::: 
log.nmbd 
:::::::::::::: 
[2004/10/27 09:19:12, 0] nmbd/nmbd.c:main(664) 
  Netbios nameserver version 3.0.7-SerNet-SuSE started. 
  Copyright Andrew Tridgell and the Samba Team 1994-2004 
:::::::::::::: 
log.smbd 
:::::::::::::: 
[2004/10/27 09:19:12, 0] smbd/server.c:main(760) 
  smbd version 3.0.7-SerNet-SuSE started. 
  Copyright Andrew Tridgell and the Samba Team 1992-2004 
:::::::::::::: 
log.winbindd 
:::::::::::::: 
[2004/10/27 09:19:13, 1] nsswitch/winbindd.c:main(854) 
  winbindd version 3.0.7-SerNet-SuSE started. 
  Copyright The Samba Team 2000-2004 
:::::::::::::: 
smbd.log 
:::::::::::::: 
:::::::::::::: 
winbindd.log 
:::::::::::::: 
[2004/10/27 09:19:15, 1] libsmb/clikrb5.c:ads_krb5_mk_req(313) 
  krb5_cc_get_principal failed (No such file or directory) 
Comment 4 Gerald (Jerry) Carter 2004-10-26 17:49:15 UTC
not the same error (nor should it be causing problems).
Is something not working as you think it should?
Comment 5 Mustafa Mehmed 2004-10-26 18:08:19 UTC
Thanks Jerry. Trying to get ADS authentication to work and can't do it. It may 
be a set up problem here?? Don't really know. 
 
(In reply to comment #4) 
> not the same error (nor should it be causing problems). 
> Is something not working as you think it should? 
 
 
Comment 6 Gerald (Jerry) Carter 2004-10-28 07:04:06 UTC
closing since the original bug has been addressed (bug in 
heimdal version shipped with stock SuSE 9.1 prof).