Bug 1918 - uNCName filled with hostname instead of netbiosname
uNCName filled with hostname instead of netbiosname
Status: RESOLVED DUPLICATE of bug 1910
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.7
x86 Windows XP
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 00:24 UTC by Michael Arlt
Modified: 2004-10-12 03:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Arlt 2004-10-12 00:24:32 UTC
We included the printing-patch from #1519.

hostname: vmdb07t # joined active directory 2003

relevant part of smb.conf (test for a clustered system with a floating ip&name):
        interfaces = 10.96.70.26
        bind interfaces only = Yes
        socket address = 10.96.70.26
        netbios name = sambatest

when we connect to a configured printers via point and print we get an registry 
entry "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Print\Providers\LanMan Print 
Services\Servers\sambatest\Printers\lanp099\DsSpooler"

The value for "uNCName" is "\\VMDB07T\lanp099" but should 
be "\\sambatest\lanp099". We assume problems when switching our productive 
samba-application to the other host.

Another problem is: If you don't set "netbios name" the value of "uNCName" is 
set to \\fqdn\printer for example: \\vmdb07t.universa.de\lanp099.
Comment 1 Gerald (Jerry) Carter 2004-10-12 03:50:29 UTC

*** This bug has been marked as a duplicate of 1910 ***