Bug 1901 - Files opened in smbfs-mounted directories are always opened in "Write+Read" mode
Files opened in smbfs-mounted directories are always opened in "Write+Read" mode
Status: RESOLVED DUPLICATE of bug 1902
Product: Samba 3.0
Classification: Unclassified
Component: smbmount (unmaintained)
3.0.7
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-10 01:14 UTC by Rob Swindell
Modified: 2004-10-11 15:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Swindell 2004-10-10 01:14:30 UTC
Reading a file in an smbfs-mounted directory with "tail -f" or a custom test 
application that just uses fopen(filename, "r"), the file should show as being 
opened in "Read" mode on the file server (Computer Management->System Tools-
>Shared Folders->Open Files). Instead (Windows 2000 SP4 in this case) shows the 
file is opened in "Write+Read" mode.

The clent in this test case is Fedora Core 2 and samba/smbmount Version 3.0.7-
2.FC2.
Comment 1 Björn Jacke 2004-10-10 15:34:40 UTC

*** This bug has been marked as a duplicate of 1902 ***
Comment 2 Rob Swindell 2004-10-11 15:43:39 UTC
This bug is *not* a duplicate of 1902.

<sigh>

Bug 1902 has to do with files being left-open on the file server even when 
closed on the client.