Bug 1886 - "parameter delete readonly = no" in a share don't work correctly with Xp SP2
"parameter delete readonly = no" in a share don't work correctly with Xp SP2
Status: RESOLVED DUPLICATE of bug 2227
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.7
x86 Windows XP
: P3 enhancement
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 12:00 UTC by emmanuel.pinateau
Modified: 2005-02-19 09:33 UTC (History)
1 user (show)

See Also:


Attachments
Proposed patch (3.97 KB, patch)
2004-10-15 20:02 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description emmanuel.pinateau 2004-10-07 12:00:06 UTC
"parameter delete readonly = no" in a share don't work correctly with Xp SP2 
but it's ok with Xp SP1 an Win98.

With Xp sp2 you can delete all the read only files even when you aren't the 
owners....

normal ?????  I don't think
Comment 1 Jeremy Allison 2004-10-15 20:02:28 UTC
Created attachment 732 [details]
Proposed patch
Comment 2 Jeremy Allison 2004-10-15 20:03:08 UTC
I think this patch fixes the problem. Please test.
Jeremy.
Comment 3 emmanuel.pinateau 2004-10-16 13:56:29 UTC
Ok the patch works fine !!
 
But when the parameters map hidden, system, archive = no and 
store dos attributes and ea support = yes, 
there is a problem, you must use the ACL AND the delete read only bit for the 
same result !!!!
Comment 4 Gerald (Jerry) Carter 2005-02-19 09:33:56 UTC

*** This bug has been marked as a duplicate of 2227 ***