Bug 1859 - no servername distributed for printers -> only ip-address
no servername distributed for printers -> only ip-address
Status: RESOLVED DUPLICATE of bug 1519
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.7
Sparc Solaris
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-30 09:10 UTC by Ralf Brunckhorst
Modified: 2004-10-01 07:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Brunckhorst 2004-09-30 09:10:13 UTC
Since version 3.0.6 the win2k client (no other client tested) get as servername
by every printer only the ip-address.
You can check it with rpcclient ... "enumprinters"
until version 3.0.5 you get the servername (netbios-name)
but since 3.0.6 you only get an IP
Example:
3.0.5
flags:[0x800000]
        name:[\\printserv1\bw-b35a3]
        description:[\\printserv1\bw-b35a3,bw-b35a3,HP LaserJet 8150 PS [A3]
(Room: B355)]
        comment:[HP LaserJet 8150 PS [A3] (Room: B355)]
3.0.7flags:[0x800000]
        name:[\\164.48.136.2\bw-b35a3]
        description:[\\164.48.136.2\bw-b35a3,bw-b35a3,HP LaserJet 8150 PS [A3]
(Room: B355)]
        comment:[HP LaserJet 8150 PS [A3] (Room: B355)]
The affect is that for the client after upgrading the samba-version they are
confused and think that ar new printer. You canot delete the old-printers only
with regedit.
Is this volitional?
Comment 1 Gerald (Jerry) Carter 2004-10-01 07:04:51 UTC

*** This bug has been marked as a duplicate of 1519 ***