Bug 1847 - LDAP anonymous bind for the ldapsam backend
LDAP anonymous bind for the ldapsam backend
Status: RESOLVED LATER
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.7
All Linux
: P3 enhancement
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 1041 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 03:52 UTC by Szombathelyi György
Modified: 2006-04-08 22:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szombathelyi György 2004-09-29 03:52:13 UTC
It would be good to have anonymous bind ability to a ldapsam backend. At first
hear, it would sound crazy, but if you use ldapi:/// (LDAP over domain sockets)
URL to the LDAP server (where the LDAP server and the Samba PDC is on the same
machine - a common setup, I think), there's no need for authentication, since
the permissions controlled by the normal UNIX access control mechanisms.
So I think when the "ldap admin dn" option is missing, Samba should try an
anonymous bind.
Comment 1 Gerald (Jerry) Carter 2005-02-08 21:10:24 UTC
descent idea but a little dangerous due to how Samba implemented
the ldapsam passdb backend.  Marking for later if possible.
Comment 2 Gerald (Jerry) Carter 2006-04-08 22:54:17 UTC
*** Bug 1041 has been marked as a duplicate of this bug. ***