Bug 183 - Can NOT add NTgroups
Summary: Can NOT add NTgroups
Status: CLOSED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts (show other bugs)
Version: 3.0.0preX
Hardware: All other
: P2 enhancement
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-21 14:22 UTC by John H Terpstra (mail address dead(
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments
smb.conf file for domain member server (825 bytes, application/octet-stream)
2003-06-21 14:25 UTC, John H Terpstra (mail address dead(
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John H Terpstra (mail address dead( 2003-06-21 14:22:07 UTC
linux:/etc/samba # groupadd account
linux:/etc/samba # net groupmap add ntgroup=Accounting unixgroup=account type=d
Usage: net groupmap add {rid=<int>|sid=<string>} unixgroup=<string>
[type=<domain|local|builtin>] [ntgroup=<string>] [comment=<string>]
Comment 1 John H Terpstra (mail address dead( 2003-06-21 14:25:40 UTC
Created attachment 33 [details]
smb.conf file for domain member server

Note: The problem is present on the Domain Contoller also.

Code is current CVS as of June 21, 2003, MDT 01:00am
Comment 2 John H Terpstra (mail address dead( 2003-06-21 16:30:48 UTC
I have checked the code. It is failing due to the RID or SID net being specified.
My in goodness name is it necessary to specify this? This will bite us!

Surely this would make more sense if:

a) Where a SID or RID is not specified that it gets that from the default domain
name (workgroup) in smb.conf

b) Where a -S or -w option is provided that we obtain the SID from that machine
or domain

Can someone look at this please. This is simple thing to fix.
Comment 3 Andrew Bartlett 2003-06-21 18:39:20 UTC
It's not a segfault, and it's behaving as documetented, so lower these
severities back to reality....
Comment 4 John H Terpstra (mail address dead( 2003-10-19 16:33:59 UTC
Works in 3.0.0 release.
Comment 5 Gerald (Jerry) Carter 2005-02-07 08:39:11 UTC
originally reported against 3.0.0beta1.  CLeaning out 
non-production release versions.
Comment 6 Gerald (Jerry) Carter 2005-08-24 10:17:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.